Cross-site Scripting (XSS) in phpipam/phpipam
A Cross-Site Scripting (XSS) vulnerability in phpipam/phpipam versions prior to 1.4.7 allows attackers to execute arbitrary JavaScript code in the browser of a victim. This vulnerability affects the import Data set feature via a spreadsheet file upload. The affected endpoints include import-vlan-preview.php, import-subnets-preview.php, import-vrf-preview.php, import-ipaddr-preview.php, import-devtype-preview.php, import-devices-preview.php, and import-l2dom-preview.php. The vulnerability can be exploited by uploading a specially crafted spreadsheet file containing malicious JavaScript payloads, which are then executed in the context of the victim's browser. This can lead to defacement of websites, execution of malicious JavaScript code, stealing of user cookies, and unauthorized access to user accounts.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-1226
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 13:01 UTC · Revision 1
Source evidence
Cross-site Scripting (XSS) in phpipam/phpipam
core-osv · Original sourcePublished 15 Nov 2024, 10:57 UTC
A Cross-Site Scripting (XSS) vulnerability in phpipam/phpipam versions prior to 1.4.7 allows attackers to execute arbitrary JavaScript code in the browser of a victim. This vulnerability affects the import Data set feature via a spreadsheet file upload. The affected endpoints include import-vlan-preview.php, import-subnets-preview.php, import-vrf-preview.php, import-ipaddr-preview.php, import-devtype-preview.php, import-devices-preview.php, and import-l2dom-preview.php. The vulnerability can be exploited by uploading a specially crafted spreadsheet file containing malicious JavaScript payloads, which are then executed in the context of the victim's browser. This can lead to defacement of websites, execution of malicious JavaScript code, stealing of user cookies, and unauthorized access to user accounts.
osv:CVE-2022-1226
Complete source record
{
"id": "30eca9f9a06fe0e132dc9b8af654adcc7021c4d7cdfecc8c1ba79e333f7e0da8",
"url": "https://osv.dev/vulnerability/CVE-2022-1226",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Cross-site Scripting (XSS) in phpipam/phpipam",
"summary": "A Cross-Site Scripting (XSS) vulnerability in phpipam/phpipam versions prior to 1.4.7 allows attackers to execute arbitrary JavaScript code in the browser of a victim. This vulnerability affects the import Data set feature via a spreadsheet file upload. The affected endpoints include import-vlan-preview.php, import-subnets-preview.php, import-vrf-preview.php, import-ipaddr-preview.php, import-devtype-preview.php, import-devices-preview.php, and import-l2dom-preview.php. The vulnerability can be exploited by uploading a specially crafted spreadsheet file containing malicious JavaScript payloads, which are then executed in the context of the victim's browser. This can lead to defacement of websites, execution of malicious JavaScript code, stealing of user cookies, and unauthorized access to user accounts.",
"evidence": "osv:CVE-2022-1226",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2022-1226",
"aliases": [
"CVE-2022-1226"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpipam/phpipam",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "8ef996678cccf3e0b1ba01e24e16fb8e7dbdb0a6"
},
{
"fixed": "50e36b9e4fff5eaa51dc6e42bc684748da378002"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.4.7"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "50e36b9e4fff5eaa51dc6e42bc684748da378002"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.4.6",
"v1.4.5",
"v1.4.4",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.2",
"v1.3.0",
"v1.2.0_beta2",
"v1.19.008",
"v1.16.003"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-1226.json"
}
}
],
"modified": "2026-10-28T02:30:28.806623749Z",
"provider": "osv",
"references": [
"https://huntr.com/bounties/3fdcf653-fe26-4592-94a1-98ce664618ec",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1226.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-1226",
"https://github.com/phpipam/phpipam/commit/50e36b9e4fff5eaa51dc6e42bc684748da378002"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "@huntr_ai",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1226.json"
}
},
"related_cves": [
{
"value": "CVE-2022-1226",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 495641,
"published_at": "2024-11-15T10:57:20.597+00:00"
}