High
Security advisory
PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-15560
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:17 UTC · Revision 1
Source evidence
PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.
osv:CVE-2018-15560
Complete source record
{
"id": "2b6e14608a1369ee32520a3c6b5ebaba431bc366fd3ff3ebba79f1f570133999",
"url": "https://osv.dev/vulnerability/CVE-2018-15560",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-15560",
"summary": "PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.",
"evidence": "osv:CVE-2018-15560",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-15560",
"aliases": [
"CVE-2018-15560",
"GHSA-hgg3-g7gr-66r7",
"PYSEC-2018-21"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/legrandin/pycryptodome",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9788edcd38f2104ae6def75caab90346eb3d4c69"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:pycryptodome:pycryptodome:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.6.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.6.6",
"v3.6.5",
"v3.6.4",
"v3.6.3",
"v3.6.2",
"v3.6.1",
"v3.6.0",
"v3.5.1",
"v3.4.12",
"v3.4.11",
"v3.4.10",
"v3.4.9",
"v3.4.8",
"v3.4.6",
"v3.4.5",
"v3.4.4",
"v3.4.3",
"v3.3",
"v3.4.2",
"v3.4.1",
"v3.4",
"v3.3.1",
"v3.2.1",
"v3.2",
"v3.1",
"v3.0",
"v3.0rc3",
"v3.0rc2",
"v3.0rc1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-15560.json"
}
}
],
"modified": "2026-10-20T10:50:04.145344292Z",
"provider": "osv",
"references": [
"https://github.com/Legrandin/pycryptodome/issues/198",
"https://whitehatck01.blogspot.com/2018/08/integer-overflow-vulnerability-in.html"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-15560",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 381226,
"published_at": "2018-08-20T00:29:00.697+00:00"
}