Skip to content
Heist/ feed
Back to feed
HighFix available

exim4 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2020-28013

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the command line, and thus may allow privilege escalation from any user to root. This occurs because of the interpretation of negative sizes in strncpy.

Products
exim4
Affected versions
Not specified
Fixed versions
4.94.2-1
CVEs
CVE-2020-28013
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 13:30 UTC · Revision 1

Source evidence

DEBIAN-CVE-2020-28013

core-osv · Original source

Published 6 May 2021, 13:15 UTC

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the command line, and thus may allow privilege escalation from any user to root. This occurs because of the interpretation of negative sizes in strncpy.

osv:DEBIAN-CVE-2020-28013

exim4

Fixed versions: 4.94.2-1

exim4

Fixed versions: 4.94.2-1

exim4

Fixed versions: 4.94.2-1

Complete source record
{
  "id": "922f10e1a5567b7fbcdd6b84b2b06bca66391dd57cacb2427153060ae77ea2fd",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2020-28013",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2020-28013",
    "summary": "Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles \"-F '.('\" on the command line, and thus may allow privilege escalation from any user to root. This occurs because of the interpretation of negative sizes in strncpy.",
    "evidence": "osv:DEBIAN-CVE-2020-28013",
    "products": [
      {
        "name": {
          "value": "exim4",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.94.2-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "exim4",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.94.2-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "exim4",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.94.2-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2020-28013",
      "aliases": [
        "DEBIAN-CVE-2020-28013"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.94.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "exim4",
            "purl": "pkg:deb/debian/exim4?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-28013.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.94.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "exim4",
            "purl": "pkg:deb/debian/exim4?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-28013.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.94.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "exim4",
            "purl": "pkg:deb/debian/exim4?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-28013.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-26T12:02:31.152741384Z",
      "provider": "osv",
      "upstream": [
        "CVE-2020-28013"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2020-28013"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2020-28013",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 452426,
  "published_at": "2021-05-06T13:15:09.43+00:00"
}