pygresql — security advisory
PostgreSQL 8.1.x before 8.1.4, 8.0.x before 8.0.8, 7.4.x before 7.4.13, 7.3.x before 7.3.15, and earlier versions allows context-dependent attackers to bypass SQL injection protection methods in applications that use multibyte encodings that allow the "\" (backslash) byte 0x5c to be the trailing byte of a multibyte character, such as SJIS, BIG5, GBK, GB18030, and UHC, which cannot be handled correctly by a client that does not understand multibyte encodings, aka a second variant of "Encoding-Based SQL Injection." NOTE: it could be argued that this is a class of issue related to interaction errors between the client and PostgreSQL, but a CVE has been assigned since PostgreSQL is treating this as a preventative measure against this class of problem.
- Products
- pygresql
- Affected versions
- Not specified
- Fixed versions
- 3.8-1.1
- CVEs
- CVE-2006-2314
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:17 UTC · Revision 1
Source evidence
PostgreSQL 8.1.x before 8.1.4, 8.0.x before 8.0.8, 7.4.x before 7.4.13, 7.3.x before 7.3.15, and earlier versions allows context-dependent attackers to bypass SQL injection protection methods in applications that use multibyte encodings that allow the "\" (backslash) byte 0x5c to be the trailing byte of a multibyte character, such as SJIS, BIG5, GBK, GB18030, and UHC, which cannot be handled correctly by a client that does not understand multibyte encodings, aka a second variant of "Encoding-Based SQL Injection." NOTE: it could be argued that this is a class of issue related to interaction errors between the client and PostgreSQL, but a CVE has been assigned since PostgreSQL is treating this as a preventative measure against this class of problem.
osv:DEBIAN-CVE-2006-2314
pygresql
Fixed versions: 3.8-1.1
pygresql
Fixed versions: 3.8-1.1
pygresql
Fixed versions: 3.8-1.1
Complete source record
{
"id": "e0acb09200b45bebafe4aab93ddd8fa60cbe60479b40c0caccdc120efc23c1ea",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2006-2314",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2006-2314",
"summary": "PostgreSQL 8.1.x before 8.1.4, 8.0.x before 8.0.8, 7.4.x before 7.4.13, 7.3.x before 7.3.15, and earlier versions allows context-dependent attackers to bypass SQL injection protection methods in applications that use multibyte encodings that allow the \"\\\" (backslash) byte 0x5c to be the trailing byte of a multibyte character, such as SJIS, BIG5, GBK, GB18030, and UHC, which cannot be handled correctly by a client that does not understand multibyte encodings, aka a second variant of \"Encoding-Based SQL Injection.\" NOTE: it could be argued that this is a class of issue related to interaction errors between the client and PostgreSQL, but a CVE has been assigned since PostgreSQL is treating this as a preventative measure against this class of problem.",
"evidence": "osv:DEBIAN-CVE-2006-2314",
"products": [
{
"name": {
"value": "pygresql",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8-1.1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pygresql",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8-1.1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pygresql",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8-1.1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2006-2314",
"aliases": [
"DEBIAN-CVE-2006-2314"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8-1.1"
}
]
}
],
"package": {
"name": "pygresql",
"purl": "pkg:deb/debian/pygresql?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2314.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8-1.1"
}
]
}
],
"package": {
"name": "pygresql",
"purl": "pkg:deb/debian/pygresql?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2314.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8-1.1"
}
]
}
],
"package": {
"name": "pygresql",
"purl": "pkg:deb/debian/pygresql?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-2314.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
}
],
"modified": "2026-10-22T23:47:30.292377429Z",
"provider": "osv",
"upstream": [
"CVE-2006-2314"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2006-2314"
]
},
"related_cves": [
{
"value": "CVE-2006-2314",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 410712,
"published_at": "2006-05-24T10:06:00+00:00"
}