OctoPrint Authenticated Reverse Proxy Page Authentication Bypass
OctoPrint provides a web interface for controlling consumer 3D printers. In versions up to and including 1.10.3, OctoPrint has a vulnerability that allows an attacker to bypass the login redirect and directly access the rendered HTML of certain frontend pages. The primary risk lies in potential future modifications to the codebase that might incorrectly rely on the vulnerable internal functions for authentication checks, leading to security vulnerabilities. This issue has been patched in version 1.11.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-32788
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 13:26 UTC · Revision 1
Source evidence
OctoPrint Authenticated Reverse Proxy Page Authentication Bypass
core-osv · Original sourcePublished 22 Apr 2025, 17:14 UTC
OctoPrint provides a web interface for controlling consumer 3D printers. In versions up to and including 1.10.3, OctoPrint has a vulnerability that allows an attacker to bypass the login redirect and directly access the rendered HTML of certain frontend pages. The primary risk lies in potential future modifications to the codebase that might incorrectly rely on the vulnerable internal functions for authentication checks, leading to security vulnerabilities. This issue has been patched in version 1.11.0.
osv:CVE-2025-32788
Complete source record
{
"id": "1cacebff3445396bf6ea0e42107703e210edba42a77a9700a6e65b449ead4c39",
"url": "https://osv.dev/vulnerability/CVE-2025-32788",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OctoPrint Authenticated Reverse Proxy Page Authentication Bypass",
"summary": "OctoPrint provides a web interface for controlling consumer 3D printers. In versions up to and including 1.10.3, OctoPrint has a vulnerability that allows an attacker to bypass the login redirect and directly access the rendered HTML of certain frontend pages. The primary risk lies in potential future modifications to the codebase that might incorrectly rely on the vulnerable internal functions for authentication checks, leading to security vulnerabilities. This issue has been patched in version 1.11.0.",
"evidence": "osv:CVE-2025-32788",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-32788",
"aliases": [
"CVE-2025-32788",
"GHSA-qw93-h6pf-226x",
"PYSEC-2025-56"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/octoprint/octoprint",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "98cc8494362a7b9d5e769cc08f7b7f388af579ac"
},
{
"fixed": "41ff431014edfa18ca1a01897b10463934dc7fc2"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:octoprint:octoprint:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.11.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "41ff431014edfa18ca1a01897b10463934dc7fc2"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.11.0rc7",
"1.11.0rc6",
"1.11.0rc5",
"1.11.0rc4",
"1.11.0rc3",
"1.11.0rc2",
"1.11.0rc1",
"1.10.3",
"1.10.2",
"1.10.1",
"1.10.0",
"1.10.0rc1",
"1.9.3",
"1.9.2",
"1.9.0",
"1.9.0rc1",
"1.8.7",
"1.8.6",
"1.8.5",
"1.8.4",
"1.8.3",
"1.8.2",
"1.8.1",
"1.8.0",
"1.8.0rc1",
"1.7.3",
"1.7.2",
"1.7.1",
"1.7.0rc1",
"1.6.1",
"1.6.0rc1",
"1.5.3",
"1.5.2",
"1.5.1",
"1.5.0",
"1.5.0rc3",
"1.5.0rc2",
"1.5.0rc1",
"1.4.0rc6",
"1.4.0rc5",
"1.4.0rc4",
"1.4.0rc3",
"1.4.0rc2",
"1.4.0rc1",
"1.2.18",
"1.2.18rc1",
"1.2.17rc3",
"1.2.17rc2",
"1.2.17rc1",
"1.2.16",
"1.2.16rc2",
"1.2.16rc1",
"1.2.15",
"1.2.14",
"1.2.13",
"1.2.12",
"1.2.11",
"1.2.10",
"1.2.9",
"1.2.8",
"1.2.7",
"1.2.6",
"1.2.5",
"1.2.4",
"1.2.3",
"1.2.2",
"1.2.1",
"1.2.0",
"1.2.0-rc3",
"1.2.0-rc2",
"1.2.0-rc1",
"1.2.0-dev",
"1.1.0-dev"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-32788.json"
}
}
],
"modified": "2026-10-28T02:30:35.769287998Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32788.json",
"https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-qw93-h6pf-226x",
"https://nvd.nist.gov/vuln/detail/CVE-2025-32788",
"https://github.com/OctoPrint/OctoPrint/commit/41ff431014edfa18ca1a01897b10463934dc7fc2"
],
"provider_metadata": {
"cwe_ids": [
"CWE-290"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32788.json"
}
},
"related_cves": [
{
"value": "CVE-2025-32788",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503088,
"published_at": "2025-04-22T17:14:39.69+00:00"
}