Security advisory
Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-1000162
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:20 UTC · Revision 1
Source evidence
Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.
osv:CVE-2018-1000162
Complete source record
{
"id": "5fa3be5409334b3ee764da0e5e6e974117e28beb7e92f6bfb8fc33cbd632d018",
"url": "https://osv.dev/vulnerability/CVE-2018-1000162",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-1000162",
"summary": "Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.",
"evidence": "osv:CVE-2018-1000162",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2018-1000162",
"aliases": [
"CVE-2018-1000162",
"GHSA-qgpv-86r3-87fh"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/erusev/parsedown",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6678d59be48c4be64eaca6ce70bea48a09488cc2"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:parsedown:parsedown:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.6.4",
"1.6.3",
"1.6.2",
"1.6.1",
"1.6.0",
"1.5.4",
"1.5.3",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.5",
"1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0",
"1.3.0",
"1.2.0",
"1.1.4",
"1.1.3",
"1.1.2",
"1.1.1",
"1.1.0",
"1.0.1",
"1.0.0",
"1.0.0-rc.5",
"1.0.0-rc.4",
"1.0.0-rc.3",
"1.0.0-rc.2",
"1.0.0-rc.1",
"0.9.4",
"0.9.3",
"0.9.2",
"0.9.1",
"0.9.0",
"0.8.3",
"0.8.2",
"0.8.1",
"0.8.0",
"0.7.7",
"0.7.6",
"0.7.5",
"0.7.4",
"0.7.3",
"0.7.2",
"0.7.1",
"0.7.0",
"0.6.0",
"0.5.0",
"0.4.8",
"0.4.7",
"0.4.6",
"0.4.5",
"0.4.4",
"0.4.3",
"0.4.2",
"0.4.1",
"0.4.0",
"0.3.0",
"0.2.1",
"0.2.0",
"0.1.5",
"0.1.4",
"0.1.3",
"0.1.2",
"0.1.1",
"0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1000162.json"
}
}
],
"modified": "2026-10-20T10:50:14.834310209Z",
"provider": "osv",
"references": [
"https://github.com/Roave/SecurityAdvisories/issues/44#issuecomment-368594409",
"https://github.com/erusev/parsedown/pull/495"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-1000162",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 381440,
"published_at": "2018-04-18T19:29:00.583+00:00"
}