Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2017-12612

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2017-12612
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:47 UTC · Revision 1

Source evidence

CVE-2017-12612

core-osv · Original source

Published 13 Sept 2017, 16:29 UTC

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

osv:CVE-2017-12612
Complete source record
{
  "id": "5335ebd2928f849282cae85daa20c69a5609d0a8b341bbdee5b26253d824a1f8",
  "url": "https://osv.dev/vulnerability/CVE-2017-12612",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2017-12612",
    "summary": "In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.",
    "evidence": "osv:CVE-2017-12612",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2017-12612",
      "aliases": [
        "CVE-2017-12612",
        "GHSA-8rhc-48pp-52gr",
        "PYSEC-2017-147"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/spark",
              "type": "GIT",
              "events": [
                {
                  "introduced": "4062cda3087ae42c6c3cb24508fc1d3a931accdf"
                },
                {
                  "last_affected": "267aca5bd5042303a718d10635bc0d1a1596853f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:spark:1.6.0:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.6.0"
                      },
                      {
                        "last_affected": "1.6.0"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:1.6.1:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.6.1"
                      },
                      {
                        "last_affected": "1.6.1"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:1.6.2:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.6.2"
                      },
                      {
                        "last_affected": "1.6.2"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:1.6.3:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.6.3"
                      },
                      {
                        "last_affected": "1.6.3"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:2.0.0:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.0.0"
                      },
                      {
                        "last_affected": "2.0.0"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:2.0.1:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.0.1"
                      },
                      {
                        "last_affected": "2.0.1"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:2.0.2:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.0.2"
                      },
                      {
                        "last_affected": "2.0.2"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:2.1.0:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.1.0"
                      },
                      {
                        "last_affected": "2.1.0"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:spark:2.1.1:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.1.1"
                      },
                      {
                        "last_affected": "2.1.1"
                      }
                    ],
                    "source": "CPE_STRING"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.6.0",
            "1.6.1",
            "1.6.2",
            "1.6.3",
            "2.0.0",
            "2.0.1",
            "2.0.2",
            "2.1.0",
            "2.1.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-12612.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:44.524788688Z",
      "provider": "osv",
      "references": [
        "https://mail-archives.apache.org/mod_mbox/spark-dev/201709.mbox/%3CCAEccTyy-1yYuhdNgkBUg0sr9NeaZSrBKkBePdTNZbxXZNTAR-g%40mail.gmail.com%3E"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2017-12612",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 435907,
  "published_at": "2017-09-13T16:29:00.477+00:00"
}