Skip to content
Heist/ feed
Back to feed
Medium

Apache Ambari: authenticated users could perform XXE to read arbitrary files on the server

Type: advisorySources: OSV

XML External Entity injection in apache ambari versions <= 2.7.7, Users are recommended to upgrade to version 2.7.8, which fixes this issue. More Details: Oozie Workflow Scheduler had a vulnerability that allowed for root-level file reading and privilege escalation from low-privilege users. The vulnerability was caused through lack of proper user input validation. This vulnerability is known as an XML External Entity (XXE) injection attack. Attackers can exploit XXE vulnerabilities to read arbitrary files on the server, including sensitive system files. In theory, it might be possible to use this to escalate privileges.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-50380
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 18:26 UTC · Revision 1

Source evidence

Apache Ambari: authenticated users could perform XXE to read arbitrary files on the server

core-osv · Original source

Published 27 Feb 2024, 16:51 UTC

XML External Entity injection in apache ambari versions <= 2.7.7, Users are recommended to upgrade to version 2.7.8, which fixes this issue. More Details: Oozie Workflow Scheduler had a vulnerability that allowed for root-level file reading and privilege escalation from low-privilege users. The vulnerability was caused through lack of proper user input validation. This vulnerability is known as an XML External Entity (XXE) injection attack. Attackers can exploit XXE vulnerabilities to read arbitrary files on the server, including sensitive system files. In theory, it might be possible to use this to escalate privileges.

osv:CVE-2023-50380
Complete source record
{
  "id": "c7aa1b0d3c17ac66375c69457a347db1ab075076395c5fc862b99b90ddb5a733",
  "url": "https://osv.dev/vulnerability/CVE-2023-50380",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Ambari: authenticated users could perform XXE to read arbitrary files on the server",
    "summary": "XML External Entity injection in apache ambari versions <= 2.7.7, Users are recommended to upgrade to version 2.7.8, which fixes this issue. More Details: Oozie Workflow Scheduler had a vulnerability that allowed for root-level file reading and privilege escalation from low-privilege users. The vulnerability was caused through lack of proper user input validation. This vulnerability is known as an XML External Entity (XXE) injection attack. Attackers can exploit XXE vulnerabilities to read arbitrary files on the server, including sensitive system files. In theory, it might be possible to use this to escalate privileges.",
    "evidence": "osv:CVE-2023-50380",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2023-50380",
      "aliases": [
        "CVE-2023-50380",
        "GHSA-qrp9-23p7-g5mf"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/ambari",
              "type": "GIT",
              "events": [
                {
                  "introduced": "da4e607a48033ab1f359b3ace302fcf29d823e38"
                },
                {
                  "fixed": "da8f1b9b5a799bfa8e2d8aa9ab31d6d5a1cc31a0"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.7.0"
                      },
                      {
                        "fixed": "2.7.8"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "release-2.7.6-rc1",
            "release-2.7.6",
            "release-2.7.6-rc0",
            "release-2.7.5-rc0",
            "release-2.7.5",
            "release-2.7.4-rc0",
            "release-2.7.4",
            "release-2.7.3-rc2",
            "release-2.7.3",
            "release-2.7.3-rc1",
            "release-2.7.3-rc0",
            "release-2.7.1-rc0",
            "release-2.7.1",
            "release-2.7.0-rc0",
            "release-2.7.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-50380.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:22.208450092Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50380.json",
        "https://lists.apache.org/thread/qrt7mq7v7zyrh1qsh1gkg1m7clysvy32",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-50380"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-611"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "2.7.0"
                  },
                  {
                    "last_affected": "2.7.7"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50380.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-50380",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 488391,
  "published_at": "2024-02-27T16:51:33.978+00:00"
}