Skip to content
Heist/ feed
Back to feed
High

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

Type: advisorySources: OSV

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-22369
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 08:22 UTC · Revision 1

Source evidence

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

core-osv · Original source

Published 20 Feb 2024, 14:58 UTC

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

osv:CVE-2024-22369
Complete source record
{
  "id": "1bf756c1f60b65eccabb8d3b0471f116aac82ffe24c80d968c3ae1a17bfe4f61",
  "url": "https://osv.dev/vulnerability/CVE-2024-22369",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository",
    "summary": "Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1",
    "evidence": "osv:CVE-2024-22369",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-22369",
      "aliases": [
        "CVE-2024-22369",
        "GHSA-36xr-4x2f-cfj9"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/camel",
              "type": "GIT",
              "events": [
                {
                  "introduced": "ac11f88de7594232c3c28532a19377764665ce13"
                },
                {
                  "fixed": "63dc3d2bbfc14abce85fedee71499a45d746d661"
                },
                {
                  "introduced": "8d135894cd73970c82da5da0dc71ecc7f5521ad5"
                },
                {
                  "fixed": "344cacf9ea0afec8639e901868202767d2b66ce3"
                },
                {
                  "introduced": "363e7e1c93f61e23cdae808f2180908169c78f6e"
                },
                {
                  "fixed": "aab0e881d960959cce968804cc269fa38dd1aae5"
                },
                {
                  "introduced": "36f52065717df1fb86de0138c1b59a26d204cb5b"
                },
                {
                  "last_affected": "36f52065717df1fb86de0138c1b59a26d204cb5b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "3.0.0"
                      },
                      {
                        "fixed": "3.21.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.0.0"
                      },
                      {
                        "fixed": "4.0.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.1.0"
                      },
                      {
                        "fixed": "4.4.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:camel:3.22.0:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "3.22.0"
                      },
                      {
                        "last_affected": "3.22.0"
                      }
                    ],
                    "source": "CPE_STRING"
                  }
                ]
              }
            }
          ],
          "versions": [
            "3.22.0",
            "camel-3.22.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-22369.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:33.795487218Z",
      "provider": "osv",
      "references": [
        "https://repo.maven.apache.org/maven2",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/22xxx/CVE-2024-22369.json",
        "https://lists.apache.org/thread/3dko781dy2gy5l3fs48p56fgp429yb0f",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-22369"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-502"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "3.0.0"
                  },
                  {
                    "fixed": "3.21.4"
                  },
                  {
                    "introduced": "3.22.0"
                  },
                  {
                    "fixed": "3.22.1"
                  },
                  {
                    "introduced": "4.0.0"
                  },
                  {
                    "fixed": "4.0.4"
                  },
                  {
                    "introduced": "4.1.0"
                  },
                  {
                    "fixed": "4.4.0"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/22xxx/CVE-2024-22369.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-22369",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 501108,
  "published_at": "2024-02-20T14:58:36.291+00:00"
}