HighFix available
glib2.0 — security advisory
An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.
- Products
- glib2.0
- Affected versions
- Not specified
- Fixed versions
- 2.66.6-1
- CVEs
- CVE-2021-27219
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 16:51 UTC · Revision 1
Source evidence
An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.
osv:DEBIAN-CVE-2021-27219
glib2.0
Fixed versions: 2.66.6-1
glib2.0
Fixed versions: 2.66.6-1
glib2.0
Fixed versions: 2.66.6-1
Complete source record
{
"id": "3d81b53b7f17834a03b0767d4d0f139ad938440667666a0e5fc36af7999df411",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-27219",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-27219",
"summary": "An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.",
"evidence": "osv:DEBIAN-CVE-2021-27219",
"products": [
{
"name": {
"value": "glib2.0",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.66.6-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "glib2.0",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.66.6-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "glib2.0",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.66.6-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2021-27219",
"aliases": [
"DEBIAN-CVE-2021-27219"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.66.6-1"
}
]
}
],
"package": {
"name": "glib2.0",
"purl": "pkg:deb/debian/glib2.0?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-27219.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.66.6-1"
}
]
}
],
"package": {
"name": "glib2.0",
"purl": "pkg:deb/debian/glib2.0?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-27219.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.66.6-1"
}
]
}
],
"package": {
"name": "glib2.0",
"purl": "pkg:deb/debian/glib2.0?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-27219.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T09:47:42.429840518Z",
"provider": "osv",
"upstream": [
"CVE-2021-27219"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-27219"
]
},
"related_cves": [
{
"value": "CVE-2021-27219",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 328426,
"published_at": "2021-02-15T17:15:13.137+00:00"
}