High
Apache Kylin: Server-Side Request Forgery
Type: advisorySources: OSV
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-61735
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 13:21 UTC · Revision 1
Source evidence
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.
osv:CVE-2025-61735
Complete source record
{
"id": "8487c6d5e8a29551e45ad28617d6593db49bb784528be7d6d7f91f00f3aef223",
"url": "https://osv.dev/vulnerability/CVE-2025-61735",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Kylin: Server-Side Request Forgery",
"summary": "Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.",
"evidence": "osv:CVE-2025-61735",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-61735",
"aliases": [
"CVE-2025-61735",
"GHSA-f6m8-qm7j-fh65"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/kylin",
"type": "GIT",
"events": [
{
"introduced": "aa6d582c0a96fdf31e85791f86850cfc00a7644f"
},
{
"fixed": "196016ffa4b70a68439be72d75584d2f99ed23b1"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "5.0.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-61735.json"
}
}
],
"modified": "2026-10-28T02:30:35.548061993Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/61xxx/CVE-2025-61735.json",
"https://lists.apache.org/thread/yscobmx869zvprsykb94r24jtmb58ckh",
"https://nvd.nist.gov/vuln/detail/CVE-2025-61735"
],
"provider_metadata": {
"cwe_ids": [
"CWE-918"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "4.0.0"
},
{
"last_affected": "5.0.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/61xxx/CVE-2025-61735.json"
}
},
"related_cves": [
{
"value": "CVE-2025-61735",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 502988,
"published_at": "2025-10-02T09:47:49.948+00:00"
}