heimdal — security advisory
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
- Products
- heimdal
- Affected versions
- Not specified
- Fixed versions
- 7.8.git20221115.a6cf945+dfsg-1
- CVEs
- CVE-2022-41916
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:21 UTC · Revision 1
Source evidence
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
osv:DEBIAN-CVE-2022-41916
heimdal
Fixed versions: 7.8.git20221115.a6cf945+dfsg-1
heimdal
Fixed versions: 7.8.git20221115.a6cf945+dfsg-1
heimdal
Fixed versions: 7.8.git20221115.a6cf945+dfsg-1
Complete source record
{
"id": "f945311deb80988c4905eddcbbdfcb59bd09de8628ccac33d66efdd142b99648",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-41916",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-41916",
"summary": "Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.",
"evidence": "osv:DEBIAN-CVE-2022-41916",
"products": [
{
"name": {
"value": "heimdal",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7.8.git20221115.a6cf945+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "heimdal",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7.8.git20221115.a6cf945+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "heimdal",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7.8.git20221115.a6cf945+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-41916",
"aliases": [
"DEBIAN-CVE-2022-41916"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7.8.git20221115.a6cf945+dfsg-1"
}
]
}
],
"package": {
"name": "heimdal",
"purl": "pkg:deb/debian/heimdal?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41916.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7.8.git20221115.a6cf945+dfsg-1"
}
]
}
],
"package": {
"name": "heimdal",
"purl": "pkg:deb/debian/heimdal?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41916.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7.8.git20221115.a6cf945+dfsg-1"
}
]
}
],
"package": {
"name": "heimdal",
"purl": "pkg:deb/debian/heimdal?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41916.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:54.378686590Z",
"provider": "osv",
"upstream": [
"CVE-2022-41916"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-41916"
]
},
"related_cves": [
{
"value": "CVE-2022-41916",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324557,
"published_at": "2022-11-15T23:15:27.197+00:00"
}