Apache CloudStack: Improper access control in Userdata reference APIs
Missing Authorization, Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's Userdata reference APIs. Several userdata-related APIs in Apache CloudStack, including deleteUserData, linkUserDataToTemplate, resetUserDataForVirtualMachine, deployVirtualMachine, and updateVirtualMachine, exhibit missing or insufficient access control validation, potentially allowing cross-tenant/cross-account access to userdata resources that belong to other tenants. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. The deleteCniConfiguration API, introduced in 4.21.0.0, also exhibits similar behaviour and lacks access validation. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-50222
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 16:39 UTC · Revision 1
Source evidence
Apache CloudStack: Improper access control in Userdata reference APIs
core-osv · Original sourcePublished 21 Aug 2026, 08:29 UTC
Missing Authorization, Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's Userdata reference APIs. Several userdata-related APIs in Apache CloudStack, including deleteUserData, linkUserDataToTemplate, resetUserDataForVirtualMachine, deployVirtualMachine, and updateVirtualMachine, exhibit missing or insufficient access control validation, potentially allowing cross-tenant/cross-account access to userdata resources that belong to other tenants. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. The deleteCniConfiguration API, introduced in 4.21.0.0, also exhibits similar behaviour and lacks access validation. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
osv:CVE-2026-50222
Complete source record
{
"id": "862dbc8f7e0ff70a90190418722e91fadb12af8cceae7c5b36c0222ba7c147a8",
"url": "https://osv.dev/vulnerability/CVE-2026-50222",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache CloudStack: Improper access control in Userdata reference APIs",
"summary": "Missing Authorization, Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's Userdata reference APIs. Several userdata-related APIs in Apache CloudStack, including deleteUserData, linkUserDataToTemplate, resetUserDataForVirtualMachine, deployVirtualMachine, and updateVirtualMachine, exhibit missing or insufficient access control validation, potentially allowing cross-tenant/cross-account access to userdata resources that belong to other tenants. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. The deleteCniConfiguration API, introduced in 4.21.0.0, also exhibits similar behaviour and lacks access validation. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.",
"evidence": "osv:CVE-2026-50222",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-50222",
"aliases": [
"CVE-2026-50222"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/cloudstack",
"type": "GIT",
"events": [
{
"introduced": "0574087284f8b646ebc41617cfd70b3a31e3ae94"
},
{
"last_affected": "c8599040b4756034c7105806a53d2c99eb7ea0fe"
},
{
"introduced": "f9513b47bf8cda46c2cee7e31d4d662346bc7399"
},
{
"last_affected": "348ce953a99246a756b527994f7745a7be038234"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "4.18.0.0"
},
{
"last_affected": "4.20.3.0"
}
],
"source": "DESCRIPTION"
},
{
"range": [
{
"introduced": "4.21.0.0"
},
{
"last_affected": "4.22.1.0"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"4.22.1.0",
"4.20.3.0",
"4.22.0.0",
"4.21.0.0",
"4.20.1.0",
"4.20.0.0",
"4.18.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-50222.json"
}
}
],
"modified": "2026-10-28T02:30:37.266790214Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/50xxx/CVE-2026-50222.json",
"https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc",
"https://nvd.nist.gov/vuln/detail/CVE-2026-50222"
],
"provider_metadata": {
"cwe_ids": [
"CWE-200",
"CWE-862"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "4.18.0.0"
},
{
"last_affected": "4.20.3.0"
},
{
"introduced": "4.21.0.0"
},
{
"last_affected": "4.22.1.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/50xxx/CVE-2026-50222.json"
}
},
"related_cves": [
{
"value": "CVE-2026-50222",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504822,
"published_at": "2026-08-21T08:29:17.886+00:00"
}