Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-25078

A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-25078
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 12:32 UTC · Revision 1

Source evidence

CVE-2019-25078

core-osv · Original source

Published 13 Dec 2022, 18:15 UTC

A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.

osv:CVE-2019-25078
Complete source record
{
  "id": "49d5e03034c8a8499b12ad5ccb47c8bb455f5525bdd9fb2453464a899702804b",
  "url": "https://osv.dev/vulnerability/CVE-2019-25078",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-25078",
    "summary": "A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.",
    "evidence": "osv:CVE-2019-25078",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2019-25078",
      "aliases": [
        "CVE-2019-25078",
        "PYSEC-2022-43062"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/manugarg/pacparser",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "853e8f45607cb07b877ffd270c63dbcdd5201ad9"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:pacparser_project:pacparser:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.4.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "853e8f45607cb07b877ffd270c63dbcdd5201ad9"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "853e8f45607cb07b877ffd270c63dbcdd5201ad9"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.4.0"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.3.9",
            "v1.3.8",
            "1.3.7rc6",
            "1.3.7rc5",
            "1.3.7rc4",
            "1.3.7rc3",
            "1.3.7rc2",
            "1.3.7",
            "1.3.6",
            "1.3.5",
            "1.3.4",
            "1.3.3",
            "1.3.2",
            "1.3.1",
            "1.3.0",
            "1.2.9",
            "1.2.8",
            "1.2.4",
            "1.2.3",
            "1.2.1",
            "1.2.0rc3",
            "1.2.0rc2",
            "release-1.1.1",
            "release-1.1.0",
            "release-1.0.9",
            "release-1.0.8",
            "release-1.0.6",
            "trunk",
            "release-1.0.5",
            "release-1.0.4",
            "release-1.0.3",
            "release-1.0.2",
            "release-1.0.1",
            "release-1.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-25078.json",
            "vanir_signatures": [
              {
                "id": "CVE-2019-25078-03ce6594",
                "digest": {
                  "length": 1802,
                  "function_hash": "185535193883948959613470279697259945177"
                },
                "source": "https://github.com/manugarg/pacparser/commit/853e8f45607cb07b877ffd270c63dbcdd5201ad9",
                "target": {
                  "file": "src/pacparser.c",
                  "function": "pacparser_find_proxy"
                },
                "deprecated": false,
                "signature_type": "Function",
                "signature_version": "v1"
              },
              {
                "id": "CVE-2019-25078-6b1169da",
                "digest": {
                  "threshold": 0.9,
                  "line_hashes": [
                    "175973629195208611088669721819335457320",
                    "96769680040125743657258707435970794612",
                    "139557496396530274840960181807514539783",
                    "170897965285764498776469501327750529878",
                    "94581914406689708007703130807918810907",
                    "237170717333130171487512017370520743906",
                    "70801421676690435123267973840789713513"
                  ]
                },
                "source": "https://github.com/manugarg/pacparser/commit/853e8f45607cb07b877ffd270c63dbcdd5201ad9",
                "target": {
                  "file": "src/pacparser.c"
                },
                "deprecated": false,
                "signature_type": "Line",
                "signature_version": "v1"
              }
            ],
            "vanir_signatures_modified": "2026-10-20T13:46:48Z"
          }
        }
      ],
      "modified": "2026-10-20T13:46:48.031248640Z",
      "provider": "osv",
      "references": [
        "https://github.com/manugarg/pacparser/releases/tag/v1.4.0",
        "https://github.com/manugarg/pacparser/issues/99",
        "https://vuldb.com/?id.215443",
        "https://github.com/manugarg/pacparser/commit/853e8f45607cb07b877ffd270c63dbcdd5201ad9"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2019-25078",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 388235,
  "published_at": "2022-12-13T18:15:10.157+00:00"
}