Skip to content
Heist/ feed
Back to feed
Medium

Remember Me Controls <= 2.0.1 - Unauthenticated Full Path Disclosure

Type: advisorySources: OSV

The Remember Me Controls plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 2.0.1. This is due to the plugin allowing direct access to the bootstrap.php file which has display_errors on. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-7415
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 17:14 UTC · Revision 1

Source evidence

Remember Me Controls <= 2.0.1 - Unauthenticated Full Path Disclosure

core-osv · Original source

Published 6 Sept 2024, 03:30 UTC

The Remember Me Controls plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 2.0.1. This is due to the plugin allowing direct access to the bootstrap.php file which has display_errors on. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.

osv:CVE-2024-7415
Complete source record
{
  "id": "97466010d9dcd0dfe5d5e3f36ff69ae1a81fe9035e3265787a0af00157575522",
  "url": "https://osv.dev/vulnerability/CVE-2024-7415",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Remember Me Controls <= 2.0.1 - Unauthenticated Full Path Disclosure",
    "summary": "The Remember Me Controls plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 2.0.1. This is due to the plugin allowing direct access to the bootstrap.php file which has display_errors on. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.",
    "evidence": "osv:CVE-2024-7415",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-7415",
      "aliases": [
        "CVE-2024-7415"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/coffee2code/remember-me-controls",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a684b05d5072eee5cd13b4b8ffba8e46becca258"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:coffee2code:remember_me_controls:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.0.1",
            "2.0",
            "1.9.1",
            "1.9",
            "1.8.1",
            "1.8",
            "1.7",
            "1.6",
            "1.5",
            "1.4",
            "1.3",
            "1.2",
            "1.1",
            "1.0.1",
            "1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-7415.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:44.520435857Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/remember-me-controls/tags/2.0.1/tests/phpunit/bootstrap.php",
        "https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3146603%40remember-me-controls&new=3146603%40remember-me-controls&sfp_email=&sfph_mail=",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/01707346-86c2-45c8-a2c9-81a147506fa4?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/7xxx/CVE-2024-7415.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-7415"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-200"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "2.0.1"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/7xxx/CVE-2024-7415.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-7415",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 512510,
  "published_at": "2024-09-06T03:30:39.561+00:00"
}