Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-8628

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-8628
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 07:32 UTC · Revision 1

Source evidence

CVE-2016-8628

core-osv · Original source

Published 31 Jul 2018, 20:29 UTC

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.

osv:CVE-2016-8628
Complete source record
{
  "id": "dab29e91d9a81911c980a73bb4b7b3fb13c9809939c72b87d6382ff91740ec69",
  "url": "https://osv.dev/vulnerability/CVE-2016-8628",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-8628",
    "summary": "Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.",
    "evidence": "osv:CVE-2016-8628",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2016-8628",
      "aliases": [
        "CVE-2016-8628",
        "GHSA-jg4f-jqm5-4mgq",
        "PYSEC-2018-38"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/ansible/ansible",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "cdec853e37d2342346f54e51f4ec4bfbd2ee0031"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.2.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.2.0.0-0.4.rc4",
            "v2.2.0.0-0.3.rc3",
            "v2.2.0.0-0.2.rc2",
            "v2.2.0.0-0.1.rc1",
            "v2.0.0-0.5.beta3",
            "v2.0.0-0.4.beta2",
            "v2.0.0-0.3.beta1",
            "v2.0.0-0.2.alpha2",
            "v2.0.0-0.1.alpha1",
            "v1.6.0",
            "v1.4.0",
            "v1.2",
            "v1.1",
            "v1.0",
            "0.7",
            "0.3",
            "0.0.1",
            "0.01"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-8628.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:54.652881489Z",
      "provider": "osv",
      "references": [
        "https://access.redhat.com/errata/RHSA-2016:2778",
        "https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8628"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2016-8628",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 438254,
  "published_at": "2018-07-31T20:29:00.323+00:00"
}