Medium
PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability of the hyperlink base in the HTML page header
Type: advisorySources: OSV
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability of the hyperlink base in the HTML page header. The HTML page is formed without sanitizing the hyperlink base. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-56411
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 03:58 UTC · Revision 1
Source evidence
PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability of the hyperlink base in the HTML page header
core-osv · Original sourcePublished 3 Jan 2025, 17:19 UTC
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability of the hyperlink base in the HTML page header. The HTML page is formed without sanitizing the hyperlink base. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.
osv:CVE-2024-56411
Complete source record
{
"id": "0312eed8db345e90b2d9f21fb17fa1f42698e0637aa06d9023b31df9a7c8e8de",
"url": "https://osv.dev/vulnerability/CVE-2024-56411",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability of the hyperlink base in the HTML page header",
"summary": "PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability of the hyperlink base in the HTML page header. The HTML page is formed without sanitizing the hyperlink base. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.",
"evidence": "osv:CVE-2024-56411",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-56411",
"aliases": [
"CVE-2024-56411",
"GHSA-hwcp-2h35-p66w"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpoffice/phpspreadsheet",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "02c8625411dcb96e1f63d58c47460284e15b2e80"
},
{
"fixed": "2fc12fdc58d39297c7b8c72d65b37a1a25d65ab5"
},
{
"introduced": "4a77798f835119754961a97714f135826a323caa"
},
{
"fixed": "04e8b6edc1bba1bbc8e1aef4111903d11e8323c1"
},
{
"introduced": "b0993b7e4d9c860133365d115b176bc6e0f57022"
},
{
"fixed": "d836f2d7308a192441ccd1546545890b378af913"
},
{
"fixed": "45052f88e04c735d56457a8ffcdc40b2635a028e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.29.7"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.7.0"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.1.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.3.5"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "45052f88e04c735d56457a8ffcdc40b2635a028e"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"3.3.0",
"1.29.6",
"2.3.4",
"2.1.5",
"3.6.0",
"2.3.3",
"2.1.4",
"1.29.5",
"3.5.0",
"3.4.0",
"2.3.2",
"2.1.3",
"1.29.4",
"1.29.2",
"2.1.1",
"2.3.0",
"2.1.0",
"1.29.1",
"2.2.2",
"1.29.0",
"2.2.1",
"2.2.0",
"2.0.0",
"1.28.0",
"1.27.0",
"1.25.2",
"1.25.1",
"1.25.0",
"1.24.1",
"1.24.0",
"1.23.0",
"1.22.0",
"1.21.0",
"1.20.0",
"1.19.0",
"1.18.0",
"1.17.1",
"1.17.0",
"1.16.0",
"1.15.0",
"1.14.1",
"1.14.0",
"1.13.0",
"1.12.0",
"1.11.0",
"1.10.1",
"1.10.0",
"1.8.2",
"1.8.1",
"1.8.0",
"1.7.0",
"1.6.0",
"1.5.0",
"1.4.1",
"1.4.0",
"1.3.1",
"1.3.0",
"1.2.1",
"1.2.0",
"1.1.0",
"1.0.0",
"1.0.0-beta2",
"phpexcel-last-cherry-picked-commit",
"phpexcel-last-release-1.8.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-56411.json"
}
}
],
"modified": "2026-10-28T02:30:25.667561653Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56411.json",
"https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-hwcp-2h35-p66w",
"https://nvd.nist.gov/vuln/detail/CVE-2024-56411",
"https://github.com/PHPOffice/PhpSpreadsheet/commit/45052f88e04c735d56457a8ffcdc40b2635a028e"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56411.json"
}
},
"related_cves": [
{
"value": "CVE-2024-56411",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492330,
"published_at": "2025-01-03T17:19:00.339+00:00"
}