High
Mist vulnerable to user providing a Sudo binary for authentication checks
Type: advisorySources: OSV
Mist is the command-line interface for the makedeb Package Repository. Prior to version 0.9.5, a user-provided `sudo` binary via the `PATH` variable can allow a local user to run arbitrary commands on the user's system with root permissions. Versions 0.9.5 and later contain a patch. No known workarounds exist.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-39245
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 17:13 UTC · Revision 1
Source evidence
Mist vulnerable to user providing a Sudo binary for authentication checks
core-osv · Original sourcePublished 26 Sept 2022, 13:55 UTC
Mist is the command-line interface for the makedeb Package Repository. Prior to version 0.9.5, a user-provided `sudo` binary via the `PATH` variable can allow a local user to run arbitrary commands on the user's system with root permissions. Versions 0.9.5 and later contain a patch. No known workarounds exist.
osv:CVE-2022-39245
Complete source record
{
"id": "05975aaae9f1baa0f1f7b725aea42bec62013b8d3a1fea88e8f3219596eb5ffd",
"url": "https://osv.dev/vulnerability/CVE-2022-39245",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Mist vulnerable to user providing a Sudo binary for authentication checks",
"summary": "Mist is the command-line interface for the makedeb Package Repository. Prior to version 0.9.5, a user-provided `sudo` binary via the `PATH` variable can allow a local user to run arbitrary commands on the user's system with root permissions. Versions 0.9.5 and later contain a patch. No known workarounds exist.",
"evidence": "osv:CVE-2022-39245",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-39245",
"aliases": [
"CVE-2022-39245",
"GHSA-pxg4-7c7r-2ww6"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/makedeb/mist",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e257561a32cffe3c541b265097959adaea3d6b67"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.9.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "e257561a32cffe3c541b265097959adaea3d6b67"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "e257561a32cffe3c541b265097959adaea3d6b67"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v0.9.5"
},
{
"cpe": "cpe:2.3:a:makedeb:mist:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.9.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.9.4",
"v0.9.3",
"v0.9.2",
"v0.9.1",
"v0.9.0",
"v0.8.0",
"v0.7.0",
"v0.6.2",
"v0.6.1",
"v0.6.0",
"v0.5.0",
"v0.4.2",
"v0.4.1",
"v0.4.0",
"v0.3.4",
"v0.3.3",
"v0.3.2",
"v0.3.1",
"v0.3.0",
"v0.2.0",
"v0.1.1",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39245.json"
}
}
],
"modified": "2026-10-28T02:30:21.567279939Z",
"provider": "osv",
"references": [
"https://github.com/makedeb/mist/releases/tag/v0.9.5",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39245.json",
"https://github.com/makedeb/mist/security/advisories/GHSA-pxg4-7c7r-2ww6",
"https://nvd.nist.gov/vuln/detail/CVE-2022-39245",
"https://github.com/makedeb/mist/commit/e257561a32cffe3c541b265097959adaea3d6b67"
],
"provider_metadata": {
"cwe_ids": [
"CWE-287",
"CWE-305"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39245.json"
}
},
"related_cves": [
{
"value": "CVE-2022-39245",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 487599,
"published_at": "2022-09-26T13:55:10+00:00"
}