Skip to content
Heist/ feed
Back to feed
Critical

vLLM Vulnerable to Remote Code Execution via Mooncake Integration

Type: advisorySources: OSV

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-32444
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 22:12 UTC · Revision 1

Source evidence

vLLM Vulnerable to Remote Code Execution via Mooncake Integration

core-osv · Original source

Published 30 Apr 2025, 00:25 UTC

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

osv:CVE-2025-32444
Complete source record
{
  "id": "5fa9d7cf9bd65caada540a4e1c4df8d7e05239f9039b18ef803a0acbbd4bd84b",
  "url": "https://osv.dev/vulnerability/CVE-2025-32444",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "vLLM Vulnerable to Remote Code Execution via Mooncake Integration",
    "summary": "vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.",
    "evidence": "osv:CVE-2025-32444",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2025-32444",
      "aliases": [
        "CVE-2025-32444",
        "GHSA-hj4w-hm2g-p6w5",
        "PYSEC-2025-42"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/vllm-project/vllm",
              "type": "GIT",
              "events": [
                {
                  "introduced": "2d1b9baa8f57fc59912c7bcd07fd630fb9d72c9d"
                },
                {
                  "fixed": "ba41cc90e8ef7f236347b2f1599eec2cbb9e1f0d"
                },
                {
                  "fixed": "a5450f11c95847cf51a17207af9a3ca5ab569b2c"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.6.5"
                      },
                      {
                        "fixed": "0.8.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "a5450f11c95847cf51a17207af9a3ca5ab569b2c"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.8.4",
            "v0.8.3rc1",
            "v0.8.2",
            "v0.8.1",
            "v0.8.0rc2",
            "v0.8.0rc1",
            "v0.7.3",
            "v0.7.2",
            "v0.7.1",
            "v0.7.0",
            "v0.6.6.post1",
            "v0.6.6",
            "v0.6.5"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-32444.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:40.026370143Z",
      "provider": "osv",
      "references": [
        "https://github.com/vllm-project/vllm/blob/32b14baf8a1f7195ca09484de3008063569b43c5/vllm/distributed/kv_transfer/kv_pipe/mooncake_pipe.py#L179",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32444.json",
        "https://github.com/vllm-project/vllm/security/advisories/GHSA-hj4w-hm2g-p6w5",
        "https://github.com/vllm-project/vllm/security/advisories/GHSA-x3m8-f7g5-qhm7",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-32444",
        "https://github.com/vllm-project/vllm/commit/a5450f11c95847cf51a17207af9a3ca5ab569b2c"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-502"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32444.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-32444",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 507492,
  "published_at": "2025-04-30T00:25:00.655+00:00"
}