Apache APISIX: ldap-auth plugin cross-subtree identity impersonation
Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX. A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach. This issue affects Apache APISIX: from 2.11.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-75020
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 13:40 UTC · Revision 1
Source evidence
Apache APISIX: ldap-auth plugin cross-subtree identity impersonation
core-osv · Original sourcePublished 27 Aug 2026, 09:14 UTC
Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX. A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach. This issue affects Apache APISIX: from 2.11.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
osv:CVE-2026-75020
Complete source record
{
"id": "b9a1368a7688d1634290c0396c804371a97d0c3c834104e69fe066d50fe384e8",
"url": "https://osv.dev/vulnerability/CVE-2026-75020",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: ldap-auth plugin cross-subtree identity impersonation",
"summary": "Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX. A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach. This issue affects Apache APISIX: from 2.11.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.",
"evidence": "osv:CVE-2026-75020",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-75020",
"aliases": [
"BIT-apisix-2026-75020",
"CVE-2026-75020"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/apisix",
"type": "GIT",
"events": [
{
"introduced": "a694c4d1d6fe8212af50d4e8573be8aa5564d5a8"
},
{
"fixed": "0796d9c2cbedb1f8bf8194292ff526599f4fde20"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.11.0"
},
{
"fixed": "3.18.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-75020.json"
}
}
],
"modified": "2026-10-28T02:30:50.779398179Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75020.json",
"https://lists.apache.org/thread/d4007wk6dbl9mxy5h05zxwn8fsg13bxt",
"https://nvd.nist.gov/vuln/detail/CVE-2026-75020"
],
"provider_metadata": {
"cwe_ids": [
"CWE-90"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.11.0"
},
{
"last_affected": "3.17.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75020.json"
}
},
"related_cves": [
{
"value": "CVE-2026-75020",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519486,
"published_at": "2026-08-27T09:14:33.099+00:00"
}