CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-58064
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 23:50 UTC · Revision 1
Source evidence
CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package
core-osv · Original sourcePublished 3 Sept 2025, 22:02 UTC
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.
osv:CVE-2025-58064
Complete source record
{
"id": "89e38403fc1327ec53e3e3a22266d702e69e51306511c0a67bcd0a5d68be1374",
"url": "https://osv.dev/vulnerability/CVE-2025-58064",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package",
"summary": "CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.",
"evidence": "osv:CVE-2025-58064",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2025-58064",
"aliases": [
"CVE-2025-58064",
"GHSA-x9gp-vjh6-3wv6"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ckeditor/ckeditor5",
"type": "GIT",
"events": [
{
"introduced": "dbfa58ae1555371afa7850fa31e5400e7729390c"
},
{
"fixed": "ef1998b371b9a7bd5c33cea8d370445509e3298a"
},
{
"introduced": "6b7f659ce35b095ed28274bf904ab1b7fcfbabe0"
},
{
"fixed": "b710f224d84cfd3174a7e1ae50055292bde75516"
},
{
"fixed": "b210e90c6cf84e662ef6c7daf93a92355a961bf2"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "46.0.0"
},
{
"fixed": "46.0.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "44.2.0"
},
{
"fixed": "45.2.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "b210e90c6cf84e662ef6c7daf93a92355a961bf2"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v45.2.1",
"v46.0.2",
"v46.0.1",
"v46.0.0",
"v45.2.0",
"v45.1.0",
"v45.0.0",
"v44.3.0",
"v44.2.1",
"v44.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-58064.json"
}
}
],
"modified": "2026-10-28T02:30:24.410770467Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58064.json",
"https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-x9gp-vjh6-3wv6",
"https://nvd.nist.gov/vuln/detail/CVE-2025-58064",
"https://github.com/ckeditor/ckeditor5/commit/b210e90c6cf84e662ef6c7daf93a92355a961bf2"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58064.json"
}
},
"related_cves": [
{
"value": "CVE-2025-58064",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490988,
"published_at": "2025-09-03T22:02:53.296+00:00"
}