ZoneMinder vulnerable to Missing Authorization
ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 are vulnerable to Unauthenticated Remote Code Execution via Missing Authorization. There are no permissions check on the snapshot action, which expects an id to fetch an existing monitor but can be passed an object to create a new one instead. TriggerOn ends up calling shell_exec using the supplied Id. This issue is fixed in This issue is fixed in versions 1.36.33 and 1.37.33.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-26035
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 23:31 UTC · Revision 1
Source evidence
ZoneMinder vulnerable to Missing Authorization
core-osv · Original sourcePublished 25 Feb 2023, 01:07 UTC
ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 are vulnerable to Unauthenticated Remote Code Execution via Missing Authorization. There are no permissions check on the snapshot action, which expects an id to fetch an existing monitor but can be passed an object to create a new one instead. TriggerOn ends up calling shell_exec using the supplied Id. This issue is fixed in This issue is fixed in versions 1.36.33 and 1.37.33.
osv:CVE-2023-26035
Complete source record
{
"id": "714f798ef363034fe553975b4c39324ac354d1718756063111328c32ea7c8400",
"url": "https://osv.dev/vulnerability/CVE-2023-26035",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ZoneMinder vulnerable to Missing Authorization",
"summary": "ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 are vulnerable to Unauthenticated Remote Code Execution via Missing Authorization. There are no permissions check on the snapshot action, which expects an id to fetch an existing monitor but can be passed an object to create a new one instead. TriggerOn ends up calling shell_exec using the supplied Id. This issue is fixed in This issue is fixed in versions 1.36.33 and 1.37.33.",
"evidence": "osv:CVE-2023-26035",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-26035",
"aliases": [
"CVE-2023-26035",
"GHSA-72rg-h4vf-29gr"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/zoneminder/zoneminder",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "034ed3e21bad3050373300ab35083c86eda8d690"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.36.33"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.36.33"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.36.32",
"1.36.26",
"1.36.25",
"1.36.24",
"1.36.23",
"1.36.22",
"1.36.21",
"1.36.20",
"1.36.18",
"1.36.17",
"list",
"1.36.14",
"1.36.4",
"1.36.3",
"1.36.2",
"1.36.1",
"1.36.0",
"1.34.0",
"1.32.3",
"v1.26.3",
"v1.26.2",
"v1.26.1",
"v1.26.0",
"v1.25"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-26035.json"
}
}
],
"modified": "2026-10-28T02:30:40.313377313Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26035.json",
"https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-72rg-h4vf-29gr",
"https://nvd.nist.gov/vuln/detail/CVE-2023-26035"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "GitHub_M",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "1.37.0"
},
{
"fixed": "1.37.33"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26035.json"
}
},
"related_cves": [
{
"value": "CVE-2023-26035",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 507983,
"published_at": "2023-02-25T01:07:01.906+00:00"
}