Medium
Security advisory
Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-25979
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 08:41 UTC · Revision 1
Source evidence
Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.
osv:CVE-2022-25979
Complete source record
{
"id": "a3a059680280ed644732a8564a4b3b9285c4716afd3c2b911c89513adb2c756f",
"url": "https://osv.dev/vulnerability/CVE-2022-25979",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2022-25979",
"summary": "Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.",
"evidence": "osv:CVE-2022-25979",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-25979",
"aliases": [
"CVE-2022-25979",
"GHSA-r4hg-4cpq-q57c"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jsuites/jsuites",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "b31770d5fe91684a00177f629aab933139c32d9f"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"fixed": "b31770d5fe91684a00177f629aab933139c32d9f"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v4.17.5",
"v4.9.11",
"v4.4.2",
"v3.9.9",
"v3.7.0",
"v3.5.0",
"v3.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-25979.json"
}
}
],
"modified": "2026-10-28T02:30:50.225019078Z",
"provider": "osv",
"references": [
"https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3253331",
"https://security.snyk.io/vuln/SNYK-JS-JSUITES-3226764",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/25xxx/CVE-2022-25979.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-25979",
"https://github.com/jsuites/jsuites/issues/134",
"https://github.com/jsuites/jsuites/commit/b31770d5fe91684a00177f629aab933139c32d9f"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "snyk",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "5.0.1"
},
{
"fixed": "*"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
},
{
"extracted_events": [
{
"range": [
{
"fixed": "5.0.1"
}
],
"source": "DESCRIPTION"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/25xxx/CVE-2022-25979.json"
}
},
"related_cves": [
{
"value": "CVE-2022-25979",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 518783,
"published_at": "2023-01-31T05:00:02.448+00:00"
}