Dalli Meta Protocol request_formatter.rb self.meta_set injection
A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-4064
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 02:10 UTC · Revision 1
Source evidence
Dalli Meta Protocol request_formatter.rb self.meta_set injection
core-osv · Original sourcePublished 19 Nov 2022, 00:00 UTC
A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.
osv:CVE-2022-4064
Complete source record
{
"id": "30c0f07c82b20cc4999b893ebd53934a1891bf0f9fdbc31cede09751098a1b97",
"url": "https://osv.dev/vulnerability/CVE-2022-4064",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Dalli Meta Protocol request_formatter.rb self.meta_set injection",
"summary": "A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.",
"evidence": "osv:CVE-2022-4064",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-4064",
"aliases": [
"CVE-2022-4064",
"GHSA-3xg8-cc8f-9wv2"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/petergoldstein/dalli",
"type": "GIT",
"events": [
{
"introduced": "dc06a6adb0f5f481a60c782f75154e686593f4f3"
},
{
"fixed": "48d594dae55934476fec61789e7a7c3700e0f50d"
},
{
"fixed": "23b246573fb77621441e386cf86be02ca0781898"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "3.2.0"
},
{
"last_affected": "3.2.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "3.2.1"
},
{
"last_affected": "3.2.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "3.2.2"
},
{
"last_affected": "3.2.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "48d594dae55934476fec61789e7a7c3700e0f50d"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "23b246573fb77621441e386cf86be02ca0781898"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v3.2.3"
}
]
}
}
],
"versions": [
"3.2.0",
"3.2.1",
"3.2.2",
"v3.2.2",
"v3.2.1",
"v3.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-4064.json"
}
}
],
"modified": "2026-10-28T02:30:41.784623402Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4064.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-4064",
"https://vuldb.com/?id.214026",
"https://github.com/advisories/GHSA-3xg8-cc8f-9wv2",
"https://github.com/petergoldstein/dalli/issues/932",
"https://github.com/petergoldstein/dalli/pull/933",
"https://vuldb.com/?ctiid.214026",
"https://github.com/petergoldstein/dalli/commit/48d594dae55934476fec61789e7a7c3700e0f50d",
"https://github.com/petergoldstein/dalli/releases/tag/v3.2.3"
],
"provider_metadata": {
"cwe_ids": [
"CWE-707",
"CWE-74"
],
"cna_assigner": "VulDB",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4064.json"
}
},
"related_cves": [
{
"value": "CVE-2022-4064",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509405,
"published_at": "2022-11-19T00:00:00+00:00"
}