UnratedFix available
rails — security advisory
Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.
- Products
- rails
- Affected versions
- Not specified
- Fixed versions
- 2.3.14.1
- CVEs
- CVE-2012-3464
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:59 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.
osv:DEBIAN-CVE-2012-3464
rails
Fixed versions: 2.3.14.1
rails
Fixed versions: 2.3.14.1
rails
Fixed versions: 2.3.14.1
Complete source record
{
"id": "96e86bebeaf1388a6c6b41d757d67865f3dddc10eef34b03dc83dc18e766a06b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2012-3464",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2012-3464",
"summary": "Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.",
"evidence": "osv:DEBIAN-CVE-2012-3464",
"products": [
{
"name": {
"value": "rails",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.14.1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "rails",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.14.1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "rails",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.14.1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2012-3464",
"aliases": [
"DEBIAN-CVE-2012-3464"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.14.1"
}
]
}
],
"package": {
"name": "rails",
"purl": "pkg:deb/debian/rails?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-3464.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.14.1"
}
]
}
],
"package": {
"name": "rails",
"purl": "pkg:deb/debian/rails?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-3464.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.14.1"
}
]
}
],
"package": {
"name": "rails",
"purl": "pkg:deb/debian/rails?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-3464.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-23T17:47:31.688598163Z",
"provider": "osv",
"upstream": [
"CVE-2012-3464"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2012-3464"
]
},
"related_cves": [
{
"value": "CVE-2012-3464",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 417432,
"published_at": "2012-08-10T10:34:47.89+00:00"
}