UnratedFix available
atari800 — security advisory
Multiple buffer overflows in the atari800.svgalib setuid program of the Atari 800 emulator (atari800) before 1.2.2 allow local users to gain privileges via long command line arguments, as demonstrated with the -osa_rom argument.
- Products
- atari800
- Affected versions
- 0.6.2-1, 0.8.6-2, 0.9.8a-2, 1.2.2-1woody3
- Fixed versions
- 1.3.1-2
- CVEs
- CVE-2003-0630
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:14 UTC · Revision 1
Source evidence
Multiple buffer overflows in the atari800.svgalib setuid program of the Atari 800 emulator (atari800) before 1.2.2 allow local users to gain privileges via long command line arguments, as demonstrated with the -osa_rom argument.
osv:DEBIAN-CVE-2003-0630
atari800
Fixed versions: 1.3.1-2
atari800
Fixed versions: 1.3.1-2
atari800
Fixed versions: 1.3.1-2
Complete source record
{
"id": "dc26a08878024c5400222e9fec256c36f42868be38f521e928809622659cfa31",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2003-0630",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2003-0630",
"summary": "Multiple buffer overflows in the atari800.svgalib setuid program of the Atari 800 emulator (atari800) before 1.2.2 allow local users to gain privileges via long command line arguments, as demonstrated with the -osa_rom argument.",
"evidence": "osv:DEBIAN-CVE-2003-0630",
"products": [
{
"name": {
"value": "atari800",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.3.1-2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "0.6.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.8.6-2",
"evidence": "/affected/0/versions"
},
{
"value": "0.9.8a-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.2.2-1woody3",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "atari800",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.3.1-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "0.6.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.8.6-2",
"evidence": "/affected/1/versions"
},
{
"value": "0.9.8a-2",
"evidence": "/affected/1/versions"
},
{
"value": "1.2.2-1woody3",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "atari800",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.3.1-2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "0.6.2-1",
"evidence": "/affected/2/versions"
},
{
"value": "0.8.6-2",
"evidence": "/affected/2/versions"
},
{
"value": "0.9.8a-2",
"evidence": "/affected/2/versions"
},
{
"value": "1.2.2-1woody3",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2003-0630",
"aliases": [
"DEBIAN-CVE-2003-0630"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.1-2"
}
]
}
],
"package": {
"name": "atari800",
"purl": "pkg:deb/debian/atari800?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"0.6.2-1",
"0.8.6-2",
"0.9.8a-2",
"1.2.2-1woody3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2003-0630.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.1-2"
}
]
}
],
"package": {
"name": "atari800",
"purl": "pkg:deb/debian/atari800?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"0.6.2-1",
"0.8.6-2",
"0.9.8a-2",
"1.2.2-1woody3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2003-0630.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.1-2"
}
]
}
],
"package": {
"name": "atari800",
"purl": "pkg:deb/debian/atari800?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"0.6.2-1",
"0.8.6-2",
"0.9.8a-2",
"1.2.2-1woody3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2003-0630.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-22T23:47:27.177843819Z",
"provider": "osv",
"upstream": [
"CVE-2003-0630"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2003-0630"
]
},
"related_cves": [
{
"value": "CVE-2003-0630",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 410572,
"published_at": "2003-10-20T04:00:00+00:00"
}