Skip to content
Heist/ feed
Back to feed
Unrated

Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability

Type: advisorySources: OSV

Security vulnerability in Apache bRPC <=1.6.0 on all platforms allows attackers to inject XSS code to the builtin rpcz page. An attacker that can send http request to bRPC server with rpcz enabled can inject arbitrary XSS code to the builtin rpcz page. Solution (choose one of three): 1. upgrade to bRPC > 1.6.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.6.1/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2411 3. disable rpcz feature

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-45757
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 16:38 UTC · Revision 1

Source evidence

Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability

core-osv · Original source

Published 16 Oct 2023, 08:01 UTC

Security vulnerability in Apache bRPC <=1.6.0 on all platforms allows attackers to inject XSS code to the builtin rpcz page. An attacker that can send http request to bRPC server with rpcz enabled can inject arbitrary XSS code to the builtin rpcz page. Solution (choose one of three): 1. upgrade to bRPC > 1.6.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.6.1/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2411 3. disable rpcz feature

osv:CVE-2023-45757
Complete source record
{
  "id": "07130a2dfbf532acb66e8bd98aab8921d089ae111c2fb15568169dcbff6e494a",
  "url": "https://osv.dev/vulnerability/CVE-2023-45757",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability",
    "summary": "Security vulnerability in Apache bRPC <=1.6.0 on all platforms allows attackers to inject XSS code to the builtin rpcz page. An attacker that can send http request to bRPC server with rpcz enabled can inject arbitrary XSS code to the builtin rpcz page. Solution (choose one of three): 1. upgrade to bRPC > 1.6.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.6.1/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2411 3. disable rpcz feature",
    "evidence": "osv:CVE-2023-45757",
    "products": [],
    "severity": "unknown",
    "structured": {
      "id": "CVE-2023-45757",
      "aliases": [
        "CVE-2023-45757"
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/brpc",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "14a18bcac6fca60fa8e6e4b3d222d6209de947c3"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:brpc:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.6.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.6.0",
            "1.0.0",
            "1.0.0-rc02",
            "1.0.0-rc01",
            "0.9.8-rc01",
            "0.9.7-rc02",
            "0.9.7-rc03",
            "0.9.7",
            "0.9.7-rc01",
            "0.9.6-rc03",
            "0.9.6-rc02",
            "0.9.6-rc01",
            "0.9.6",
            "0.9.5",
            "v0.9.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-45757.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:20.799820802Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/45xxx/CVE-2023-45757.json",
        "https://lists.apache.org/thread/6syxv32fqgl30brfpttrk4rfsb983hl4",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-45757"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "0.9.0"
                  },
                  {
                    "last_affected": "1.6.0"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/45xxx/CVE-2023-45757.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-45757",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 487269,
  "published_at": "2023-10-16T08:01:41.036+00:00"
}