Critical
Usage of unsafe random function in form-data for choosing boundary
Type: advisorySources: OSV
Use of Insufficiently Random Values vulnerability in form-data allows HTTP Parameter Pollution (HPP). This vulnerability is associated with program files lib/form_data.Js. This issue affects form-data: < 2.5.4, 3.0.0 - 3.0.3, 4.0.0 - 4.0.3.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-7783
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 16:49 UTC · Revision 1
Source evidence
Usage of unsafe random function in form-data for choosing boundary
core-osv · Original sourcePublished 18 Jul 2025, 16:34 UTC
Use of Insufficiently Random Values vulnerability in form-data allows HTTP Parameter Pollution (HPP). This vulnerability is associated with program files lib/form_data.Js. This issue affects form-data: < 2.5.4, 3.0.0 - 3.0.3, 4.0.0 - 4.0.3.
osv:CVE-2025-7783
Complete source record
{
"id": "7bb133cbf782061ceb1a0082c1c368833d30b28b3e9b2fbf121ed1aa79471e70",
"url": "https://osv.dev/vulnerability/CVE-2025-7783",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Usage of unsafe random function in form-data for choosing boundary",
"summary": "Use of Insufficiently Random Values vulnerability in form-data allows HTTP Parameter Pollution (HPP). This vulnerability is associated with program files lib/form_data.Js. This issue affects form-data: < 2.5.4, 3.0.0 - 3.0.3, 4.0.0 - 4.0.3.",
"evidence": "osv:CVE-2025-7783",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-7783",
"aliases": [
"CVE-2025-7783",
"GHSA-fjxv-7rqg-78g4"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/form-data/form-data",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "efe6c2693159084b18c58648e77203d1d810395b"
},
{
"fixed": "3d1723080e6577a66f17f163ecd345a21d8d0fd0"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.5.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "3d1723080e6577a66f17f163ecd345a21d8d0fd0"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v4.0.3",
"v2.5.3",
"v4.0.2",
"v2.5.2",
"v4.0.1",
"v4.0.0",
"v3.0.1",
"v2.5.1",
"v3.0.0",
"v2.5.0",
"v2.4.0",
"v2.3.2",
"v2.3.1",
"v2.3.0",
"v2.2.0",
"v2.1.4",
"v2.1.3",
"2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.0",
"v1.0.0-rc3",
"v1.0.0-rc2",
"v1.0.0-rc1",
"0.2",
"0.1.3",
"0.1.2",
"0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-7783.json"
}
}
],
"modified": "2026-10-28T02:30:30.559357500Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2025/07/msg00023.html",
"https://npmjs.com/form-data",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/7xxx/CVE-2025-7783.json",
"https://github.com/form-data/form-data/security/advisories/GHSA-fjxv-7rqg-78g4",
"https://nvd.nist.gov/vuln/detail/CVE-2025-7783",
"https://github.com/form-data/form-data/commit/3d1723080e6577a66f17f163ecd345a21d8d0fd0",
"https://github.com/form-data/form-data"
],
"provider_metadata": {
"cwe_ids": [
"CWE-330"
],
"cna_assigner": "harborist",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "3.0.0 - 3.0.3"
},
{
"last_affected": "3.0.0 - 3.0.3"
},
{
"introduced": "4.0.0 - 4.0.3"
},
{
"last_affected": "4.0.0 - 4.0.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/7xxx/CVE-2025-7783.json"
}
},
"related_cves": [
{
"value": "CVE-2025-7783",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497594,
"published_at": "2025-07-18T16:34:44.889+00:00"
}