Skip to content
Heist/ feed
Back to feed
High

WP ERP <= 1.13.0 - Authenticated (Accounting Manager+) SQL Injection via vendor_id

Type: advisorySources: OSV

The WP ERP plugin for WordPress is vulnerable to SQL Injection via the ‘vendor_id’ and 'status' parameter in all versions up to, and including, 1.13.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Accounting Manager access (erp_ac_view_sales_summary capability) and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-6666
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 16:54 UTC · Revision 1

Source evidence

WP ERP <= 1.13.0 - Authenticated (Accounting Manager+) SQL Injection via vendor_id

core-osv · Original source

Published 11 Jul 2024, 06:43 UTC

The WP ERP plugin for WordPress is vulnerable to SQL Injection via the ‘vendor_id’ and 'status' parameter in all versions up to, and including, 1.13.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Accounting Manager access (erp_ac_view_sales_summary capability) and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

osv:CVE-2024-6666
Complete source record
{
  "id": "716885a3cfc479e08ab879bf6db080187992f35683bfab9e90af4ae0ab6ad168",
  "url": "https://osv.dev/vulnerability/CVE-2024-6666",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WP ERP <= 1.13.0 - Authenticated (Accounting Manager+) SQL Injection via vendor_id",
    "summary": "The WP ERP plugin for WordPress is vulnerable to SQL Injection via the ‘vendor_id’ and 'status' parameter in all versions up to, and including, 1.13.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Accounting Manager access (erp_ac_view_sales_summary capability) and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.",
    "evidence": "osv:CVE-2024-6666",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-6666",
      "aliases": [
        "CVE-2024-6666"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wp-erp/wp-erp",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "b60fc388fe49c656751097d0a795b8787aecc2da"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wedevs:wp_erp:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.13.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.12.9",
            "v1.12.8",
            "v1.12.7",
            "v1.12.6",
            "v1.12.5",
            "v1.12.3",
            "v1.12.2",
            "v1.12.1",
            "v1.12.0",
            "v1.11.3",
            "v1.11.2",
            "v1.11.1",
            "v1.11.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-6666.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:21.085128494Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/changeset/3064874/erp/tags/1.13.1/modules/accounting/includes/functions/transactions.php",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/e23335c9-0830-4c6b-8e0d-6897a7176ba5?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/6xxx/CVE-2024-6666.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-6666"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-89"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.13.0"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/6xxx/CVE-2024-6666.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-6666",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 487377,
  "published_at": "2024-07-11T06:43:13.765+00:00"
}