Skip to content
Heist/ feed
Back to feed
MediumFix available

openexr — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2021-23215

An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR.

Products
openexr
Affected versions
Not specified
Fixed versions
2.5.7-1
CVEs
CVE-2021-23215
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 01:41 UTC · Revision 1

Source evidence

DEBIAN-CVE-2021-23215

core-osv · Original source

Published 8 Jun 2021, 12:15 UTC

An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR.

osv:DEBIAN-CVE-2021-23215

openexr

Fixed versions: 2.5.7-1

openexr

Fixed versions: 2.5.7-1

openexr

Fixed versions: 2.5.7-1

Complete source record
{
  "id": "d558356b736ef227ccb47529b4cfc46f4fbbde36fd5526dea17103d03952f158",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-23215",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2021-23215",
    "summary": "An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR.",
    "evidence": "osv:DEBIAN-CVE-2021-23215",
    "products": [
      {
        "name": {
          "value": "openexr",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.5.7-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "openexr",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.5.7-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "openexr",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.5.7-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2021-23215",
      "aliases": [
        "DEBIAN-CVE-2021-23215"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.5.7-1"
                }
              ]
            }
          ],
          "package": {
            "name": "openexr",
            "purl": "pkg:deb/debian/openexr?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23215.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.5.7-1"
                }
              ]
            }
          ],
          "package": {
            "name": "openexr",
            "purl": "pkg:deb/debian/openexr?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23215.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.5.7-1"
                }
              ]
            }
          ],
          "package": {
            "name": "openexr",
            "purl": "pkg:deb/debian/openexr?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23215.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:04:49.361487689Z",
      "provider": "osv",
      "upstream": [
        "CVE-2021-23215"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2021-23215"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2021-23215",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 423976,
  "published_at": "2021-06-08T12:15:10.6+00:00"
}