Argo CD vulnerable to Uncontrolled Memory Consumption
Argo CD is a declarative continuous deployment for Kubernetes. Argo CD versions v0.7.0 and later are vulnerable to an uncontrolled memory consumption bug, allowing an authorized malicious user to crash the repo-server service, resulting in a Denial of Service. The attacker must be an authenticated Argo CD user authorized to deploy Applications from a repository which contains (or can be made to contain) a large file. The fix for this vulnerability is available in versions 2.3.5, 2.2.10, 2.1.16, and later. There are no known workarounds. Users are recommended to upgrade.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-31016
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 05:45 UTC · Revision 1
Source evidence
Argo CD vulnerable to Uncontrolled Memory Consumption
core-osv · Original sourcePublished 25 Jun 2022, 07:40 UTC
Argo CD is a declarative continuous deployment for Kubernetes. Argo CD versions v0.7.0 and later are vulnerable to an uncontrolled memory consumption bug, allowing an authorized malicious user to crash the repo-server service, resulting in a Denial of Service. The attacker must be an authenticated Argo CD user authorized to deploy Applications from a repository which contains (or can be made to contain) a large file. The fix for this vulnerability is available in versions 2.3.5, 2.2.10, 2.1.16, and later. There are no known workarounds. Users are recommended to upgrade.
osv:CVE-2022-31016
Complete source record
{
"id": "755ad48f3c20f87aebaffcd3d7882821bb923ae6d717d2854093f7032b1ceaf3",
"url": "https://osv.dev/vulnerability/CVE-2022-31016",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Argo CD vulnerable to Uncontrolled Memory Consumption",
"summary": "Argo CD is a declarative continuous deployment for Kubernetes. Argo CD versions v0.7.0 and later are vulnerable to an uncontrolled memory consumption bug, allowing an authorized malicious user to crash the repo-server service, resulting in a Denial of Service. The attacker must be an authenticated Argo CD user authorized to deploy Applications from a repository which contains (or can be made to contain) a large file. The fix for this vulnerability is available in versions 2.3.5, 2.2.10, 2.1.16, and later. There are no known workarounds. Users are recommended to upgrade.",
"evidence": "osv:CVE-2022-31016",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-31016",
"aliases": [
"CVE-2022-31016",
"GHSA-jhqp-vf4w-rpwq",
"GO-2022-0495"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/argoproj/argo-cd",
"type": "GIT",
"events": [
{
"introduced": "6fc345f555dff62d232fe03bf17b8bf84d7f1b5d"
},
{
"fixed": "903db5fe464032bd5a10bf32fe17639e76634c2a"
},
{
"introduced": "6da92a8e8103ce4145bb0fe2b7e952be79c9ff0a"
},
{
"fixed": "8db0e57b738ff5b0b276031573576fdc3498c04f"
},
{
"introduced": "fe427802293b090f43f91f5839393174df6c3b3a"
},
{
"fixed": "1287d24bfe47bcaa6e791e5ff12fa1c1bf57a442"
},
{
"introduced": "91aefabc5b213a258ddcfe04b8e69bb4a2dd2566"
},
{
"fixed": "52e6025f8b565705025d029e8bed36d6caa5ecf7"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:argoproj:argo_cd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.7.0"
},
{
"fixed": "2.1.16"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:argoproj:argo_cd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.2.10"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:argoproj:argo_cd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:argoproj:argo_cd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.1.15",
"v2.2.9",
"v2.4.0",
"v2.3.4",
"v2.1.14",
"v2.2.8",
"v2.3.3",
"v2.3.2",
"v2.1.13",
"v2.2.7",
"v2.1.12",
"v2.3.1",
"v2.1.11",
"v2.2.6",
"v2.3.0",
"v2.1.10",
"v2.2.5",
"v2.1.9",
"v2.2.4",
"v2.1.8",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.7",
"v2.1.2",
"v2.1.6",
"v2.1.5",
"v2.1.4",
"v2.1.3",
"v2.1.1",
"v2.1.0",
"v2.1.0-rc3",
"v2.1.0-rc2",
"v2.1.0-rc1",
"v0.8.0",
"v0.7.1",
"v0.7.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-31016.json"
}
}
],
"modified": "2026-10-28T02:30:26.262645619Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31016.json",
"https://github.com/argoproj/argo-cd/security/advisories/GHSA-jhqp-vf4w-rpwq",
"https://nvd.nist.gov/vuln/detail/CVE-2022-31016"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31016.json"
}
},
"related_cves": [
{
"value": "CVE-2022-31016",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492824,
"published_at": "2022-06-25T07:40:10+00:00"
}