HighFix available
pypdf — security advisory
pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter. This has been fixed in pypdf version 6.1.3.
- Products
- pypdf
- Affected versions
- 5.4.0-1, 6.19.0-1, 6.9.0-1, 6.9.2-1, 6.9.2-2
- Fixed versions
- 6.9.0-1
- CVEs
- CVE-2025-62708
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 11:09 UTC · Revision 1
Source evidence
pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter. This has been fixed in pypdf version 6.1.3.
osv:DEBIAN-CVE-2025-62708
pypdf
Fixed versions: Not specified
pypdf
Fixed versions: 6.9.0-1
Complete source record
{
"id": "a0c687c80e8ed297c313516b3ed48f29325c29c0ee955c5b6ad52404fcee4bc8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-62708",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-62708",
"summary": "pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter. This has been fixed in pypdf version 6.1.3.",
"evidence": "osv:DEBIAN-CVE-2025-62708",
"products": [
{
"name": {
"value": "pypdf",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.4.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.19.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.9.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.9.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.9.2-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "pypdf",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.9.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "5.4.0-1",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2025-62708",
"aliases": [
"DEBIAN-CVE-2025-62708"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "pypdf",
"purl": "pkg:deb/debian/pypdf?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"5.4.0-1",
"6.19.0-1",
"6.9.0-1",
"6.9.2-1",
"6.9.2-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-62708.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.9.0-1"
}
]
}
],
"package": {
"name": "pypdf",
"purl": "pkg:deb/debian/pypdf?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"5.4.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-62708.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-09T10:00:28.512055754Z",
"provider": "osv",
"upstream": [
"CVE-2025-62708"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-62708"
]
},
"related_cves": [
{
"value": "CVE-2025-62708",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 111732,
"published_at": "2025-10-22T22:15:35.88+00:00"
}