Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2017-5195

Irssi 0.8.17 before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted ANSI x8 color code.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2017-5195
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 04:20 UTC · Revision 1

Source evidence

CVE-2017-5195

core-osv · Original source

Published 3 Mar 2017, 15:59 UTC

Irssi 0.8.17 before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted ANSI x8 color code.

osv:CVE-2017-5195
Complete source record
{
  "id": "b6c481a89213f752aa6f262fb36214e7dee6ccf1d422b0582843bde8db19c5bd",
  "url": "https://osv.dev/vulnerability/CVE-2017-5195",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2017-5195",
    "summary": "Irssi 0.8.17 before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted ANSI x8 color code.",
    "evidence": "osv:CVE-2017-5195",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2017-5195",
      "aliases": [
        "CVE-2017-5195"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/irssi/irssi",
              "type": "GIT",
              "events": [
                {
                  "introduced": "df1df75ca2cc461360e336ce83052366002b1b8a"
                },
                {
                  "fixed": "7cac354161a8914712264408347a9a2882aab22f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:irssi:irssi:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.8.17"
                      },
                      {
                        "fixed": "0.8.21"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "0.8.20",
            "0.8.19",
            "0.8.18",
            "0.8.18-beta2",
            "0.8.17"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-5195.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:17.373830834Z",
      "provider": "osv",
      "references": [
        "https://security.gentoo.org/glsa/201701-45",
        "https://irssi.org/security/irssi_sa_2017_01.txt"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2017-5195",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 429554,
  "published_at": "2017-03-03T15:59:00.757+00:00"
}