Skip to content
Heist/ feed
Back to feed
High

Post SMTP < 2.1.7 - Admin+ Blind SSRF

Type: advisorySources: OSV

The Post SMTP Mailer/Email Log WordPress plugin before 2.1.7 does not have proper authorisation in some AJAX actions, which could allow high privilege users such as admin to perform blind SSRF on multisite installations for example.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-2352
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 01:34 UTC · Revision 1

Source evidence

Post SMTP < 2.1.7 - Admin+ Blind SSRF

core-osv · Original source

Published 26 Sept 2022, 12:35 UTC

The Post SMTP Mailer/Email Log WordPress plugin before 2.1.7 does not have proper authorisation in some AJAX actions, which could allow high privilege users such as admin to perform blind SSRF on multisite installations for example.

osv:CVE-2022-2352
Complete source record
{
  "id": "2a0d663738eb1f8303b9c863b88809b3e71ae5da0f19e80f58549d32fb1818c7",
  "url": "https://osv.dev/vulnerability/CVE-2022-2352",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Post SMTP < 2.1.7 - Admin+ Blind SSRF",
    "summary": "The Post SMTP Mailer/Email Log WordPress plugin before 2.1.7 does not have proper authorisation in some AJAX actions, which could allow high privilege users such as admin to perform blind SSRF on multisite installations for example.",
    "evidence": "osv:CVE-2022-2352",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2022-2352",
      "aliases": [
        "CVE-2022-2352"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wpexpertsio/post-smtp",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1e2224f91dc1dfd9f218ab86abeb6c6c2c58f7ca"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.1.7"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.1.6",
            "2.1.4",
            "2.1.4-rc.2",
            "2.1.4-rc.1",
            "2.1.4-beta.1",
            "2.1.2",
            "2.1.2-rc.2",
            "2.1.2-rc.1",
            "2.1.2-beta-1",
            "2.1.1.1",
            "2.1.1",
            "2.1",
            "2.1-beta.1",
            "2.0.27",
            "2.0.26",
            "2.0.25-beta.1",
            "2.0.25",
            "2.0.24",
            "2.0.23",
            "2.0.22",
            "2.0.21",
            "2.0.20",
            "2.0.19",
            "2.0.18",
            "2.0.17",
            "2.0.16",
            "2.0.15",
            "2.0.14",
            "2.0.13",
            "2.0.12",
            "2.0.11",
            "2.0.10",
            "2.0.9",
            "2.0.8",
            "2.0.7",
            "2.0.6",
            "2.0.5",
            "2.0.4",
            "2.0.3",
            "2.0.2",
            "2.0.1",
            "v1.9.8",
            "v1.9.7",
            "v1.9.6",
            "v1.9.5",
            "v1.9.4",
            "v1.9.3",
            "v.1.9.2",
            "v.1.9.1",
            "v.1.9.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-2352.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:41.286094053Z",
      "provider": "osv",
      "references": [
        "https://wpscan.com/vulnerability/dc99ac40-646a-4f8e-b2b9-dc55d6d4c55c",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2352.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-2352"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-918"
        ],
        "cna_assigner": "WPScan",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "2.1.7"
                  },
                  {
                    "last_affected": "2.1.7"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandaloneSingleVersion"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2352.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-2352",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 509139,
  "published_at": "2022-09-26T12:35:32+00:00"
}