aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration
aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-55282
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 20:21 UTC · Revision 1
Source evidence
aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration
core-osv · Original sourcePublished 18 Aug 2025, 16:44 UTC
aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.
osv:CVE-2025-55282
Complete source record
{
"id": "5f9ed79776fefad1a0b0efda4fff704b847656b4caff184c414912b49dcdf2f8",
"url": "https://osv.dev/vulnerability/CVE-2025-55282",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration",
"summary": "aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.",
"evidence": "osv:CVE-2025-55282",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-55282",
"aliases": [
"CVE-2025-55282",
"GHSA-hmvf-93r4-36f9"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/aiven/aiven-db-migrate",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "39517dc55720055d93262033b142a365f5bf92c5"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"fixed": "39517dc55720055d93262033b142a365f5bf92c5"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"0.1.8",
"0.1.7",
"0.1.6",
"0.1.5",
"0.1.4",
"0.1.3",
"0.1.2",
"0.1.1",
"0.1.0",
"0.0.6",
"0.0.5",
"0.0.4",
"0.0.3",
"0.0.2",
"0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-55282.json"
}
}
],
"modified": "2026-10-28T02:30:39.002525881Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/55xxx/CVE-2025-55282.json",
"https://github.com/aiven/aiven-db-migrate/security/advisories/GHSA-hmvf-93r4-36f9",
"https://nvd.nist.gov/vuln/detail/CVE-2025-55282",
"https://github.com/aiven/aiven-db-migrate/commit/39517dc55720055d93262033b142a365f5bf92c5"
],
"provider_metadata": {
"cwe_ids": [
"CWE-22"
],
"cna_assigner": "GitHub_M",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "1.0.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
},
{
"extracted_events": [
{
"range": [
{
"fixed": "1.0.7"
},
{
"fixed": "1.0.7"
}
],
"source": "DESCRIPTION"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/55xxx/CVE-2025-55282.json"
}
},
"related_cves": [
{
"value": "CVE-2025-55282",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 506618,
"published_at": "2025-08-18T16:44:02.944+00:00"
}