Skip to content
Heist/ feed
Back to feed
UnratedFix available

hpsockd — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2004-0993

Buffer overflow in hpsockd before 0.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code.

Products
hpsockd
Affected versions
Not specified
Fixed versions
0.14
CVEs
CVE-2004-0993
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 14:23 UTC · Revision 1

Source evidence

DEBIAN-CVE-2004-0993

core-osv · Original source

Published 10 Jan 2005, 05:00 UTC

Buffer overflow in hpsockd before 0.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code.

osv:DEBIAN-CVE-2004-0993

hpsockd

Fixed versions: 0.14

hpsockd

Fixed versions: 0.14

hpsockd

Fixed versions: 0.14

Complete source record
{
  "id": "2c1b12dfbdf86881106d9da6a05f2acbbed619c83e1fdf5a792cbca0887e602e",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2004-0993",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2004-0993",
    "summary": "Buffer overflow in hpsockd before 0.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code.",
    "evidence": "osv:DEBIAN-CVE-2004-0993",
    "products": [
      {
        "name": {
          "value": "hpsockd",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.14",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "hpsockd",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.14",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "hpsockd",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.14",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2004-0993",
      "aliases": [
        "DEBIAN-CVE-2004-0993"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.14"
                }
              ]
            }
          ],
          "package": {
            "name": "hpsockd",
            "purl": "pkg:deb/debian/hpsockd?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-0993.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.14"
                }
              ]
            }
          ],
          "package": {
            "name": "hpsockd",
            "purl": "pkg:deb/debian/hpsockd?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-0993.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.14"
                }
              ]
            }
          ],
          "package": {
            "name": "hpsockd",
            "purl": "pkg:deb/debian/hpsockd?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-0993.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-21T15:47:24.440115233Z",
      "provider": "osv",
      "upstream": [
        "CVE-2004-0993"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2004-0993"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2004-0993",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 393843,
  "published_at": "2005-01-10T05:00:00+00:00"
}