commons-configuration2 — security advisory
Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
- Products
- commons-configuration2
- Affected versions
- 2.10.1-1, 2.11.0-1, 2.11.0-2, 2.11.0-3, 2.15.1-1, 2.8.0-2
- Fixed versions
- 2.15.1-1
- CVEs
- CVE-2026-45205
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:37 UTC · Revision 2
Source evidence
Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
osv:DEBIAN-CVE-2026-45205
commons-configuration2
Fixed versions: Not specified
commons-configuration2
Fixed versions: Not specified
commons-configuration2
Fixed versions: 2.15.1-1
Complete source record
{
"id": "8340ff2b3ba216d36ba7e083b338805c1787e757f5f54620c5f9605ddc95f3e5",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-45205",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-45205",
"summary": "Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.",
"evidence": "osv:DEBIAN-CVE-2026-45205",
"products": [
{
"name": {
"value": "commons-configuration2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.10.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.11.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.11.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.11.0-3",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.8.0-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "commons-configuration2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.11.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "2.11.0-3",
"evidence": "/affected/1/versions"
},
{
"value": "2.15.1-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "commons-configuration2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.15.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "2.11.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "2.11.0-3",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2026-45205",
"aliases": [
"DEBIAN-CVE-2026-45205"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "commons-configuration2",
"purl": "pkg:deb/debian/commons-configuration2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.10.1-1",
"2.11.0-1",
"2.11.0-2",
"2.11.0-3",
"2.15.1-1",
"2.8.0-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-45205.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "commons-configuration2",
"purl": "pkg:deb/debian/commons-configuration2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.11.0-2",
"2.11.0-3",
"2.15.1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-45205.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.15.1-1"
}
]
}
],
"package": {
"name": "commons-configuration2",
"purl": "pkg:deb/debian/commons-configuration2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.11.0-2",
"2.11.0-3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-45205.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T09:47:32.849183078Z",
"provider": "osv",
"upstream": [
"CVE-2026-45205"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-45205"
]
},
"related_cves": [
{
"value": "CVE-2026-45205",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 460901,
"published_at": "2026-05-14T12:16:35.687+00:00"
}