Medium
WordPress WooCommerce and WooCommerce Blocks plugins - Auth. Cross-Site Scripting (XSS) vulnerability
Type: advisorySources: OSV
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Automattic WooCommerce, Automattic WooCommerce Blocks allows Stored XSS.This issue affects WooCommerce: from n/a through 8.1.1; WooCommerce Blocks: from n/a through 11.1.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-47777
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 16:20 UTC · Revision 1
Source evidence
WordPress WooCommerce and WooCommerce Blocks plugins - Auth. Cross-Site Scripting (XSS) vulnerability
core-osv · Original sourcePublished 30 Nov 2023, 11:56 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Automattic WooCommerce, Automattic WooCommerce Blocks allows Stored XSS.This issue affects WooCommerce: from n/a through 8.1.1; WooCommerce Blocks: from n/a through 11.1.1.
osv:CVE-2023-47777
Complete source record
{
"id": "97ba441108d9abfe19f3571756ef4abd46f2ba4659d0e9094ab17c014f877ccd",
"url": "https://osv.dev/vulnerability/CVE-2023-47777",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress WooCommerce and WooCommerce Blocks plugins - Auth. Cross-Site Scripting (XSS) vulnerability",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Automattic WooCommerce, Automattic WooCommerce Blocks allows Stored XSS.This issue affects WooCommerce: from n/a through 8.1.1; WooCommerce Blocks: from n/a through 11.1.1.",
"evidence": "osv:CVE-2023-47777",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-47777",
"aliases": [
"CVE-2023-47777"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/woocommerce/woocommerce-blocks",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "7b7253432a4e5cf17388feddca663ac1f8c398db"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:automattic:woocommerce_blocks:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "11.1.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v11.1.1-dev",
"v11.1.0-dev",
"refs/pull/6661/merge",
"ok",
"not-ok",
"v2.2.0",
"v2.1.0",
"v2.0.0-rc3",
"v2.0.0-rc2",
"v2.0.0-rc1",
"v2.0.0-beta",
"v2.0.0-alpha",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"1.2.0",
"1.1.2",
"1.1.1",
"1.1.0",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-47777.json"
}
}
],
"modified": "2026-10-28T02:30:30.303435524Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/47xxx/CVE-2023-47777.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-47777",
"https://patchstack.com/articles/authenticated-stored-xss-in-woocommerce-and-jetpack-plugin?_s_id=cve",
"https://patchstack.com/database/vulnerability/woo-gutenberg-products-block/wordpress-woocommerce-blocks-plugin-11-1-1-cross-site-scripting-xss-vulnerability?_s_id=cve",
"https://patchstack.com/database/vulnerability/woocommerce/wordpress-woocommerce-plugin-8-1-1-contributor-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "8.2.0"
},
{
"fixed": "11.1.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/47xxx/CVE-2023-47777.json"
}
},
"related_cves": [
{
"value": "CVE-2023-47777",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497300,
"published_at": "2023-11-30T11:56:53.604+00:00"
}