Skip to content
Heist/ feed
Back to feed
HighFix available

containerd — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-23648

containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.

Products
containerd
Affected versions
Not specified
Fixed versions
1.6.1~ds1-1
CVEs
CVE-2022-23648
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:43 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-23648

core-osv · Original source

Published 3 Mar 2022, 14:15 UTC

containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.

osv:DEBIAN-CVE-2022-23648

containerd

Fixed versions: 1.6.1~ds1-1

containerd

Fixed versions: 1.6.1~ds1-1

containerd

Fixed versions: 1.6.1~ds1-1

Complete source record
{
  "id": "a7e034852aa797be1aa8921f66ffa68277bf22d41d56b02b1c1b53f256da7c8d",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23648",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-23648",
    "summary": "containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.",
    "evidence": "osv:DEBIAN-CVE-2022-23648",
    "products": [
      {
        "name": {
          "value": "containerd",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.6.1~ds1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "containerd",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.6.1~ds1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "containerd",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.6.1~ds1-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2022-23648",
      "aliases": [
        "DEBIAN-CVE-2022-23648"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.6.1~ds1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "containerd",
            "purl": "pkg:deb/debian/containerd?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23648.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.6.1~ds1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "containerd",
            "purl": "pkg:deb/debian/containerd?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23648.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.6.1~ds1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "containerd",
            "purl": "pkg:deb/debian/containerd?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23648.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:01:43.584192970Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-23648"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-23648"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-23648",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323113,
  "published_at": "2022-03-03T14:15:07.973+00:00"
}