Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-15518

QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-15518
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:32 UTC · Revision 1

Source evidence

CVE-2018-15518

core-osv · Original source

Published 26 Dec 2018, 21:29 UTC

QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.

osv:CVE-2018-15518
Complete source record
{
  "id": "829dd96c6975d1f9546e0a24e7de077661dc5974cd9b7b9d638391ca35a84c40",
  "url": "https://osv.dev/vulnerability/CVE-2018-15518",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-15518",
    "summary": "QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.",
    "evidence": "osv:CVE-2018-15518",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2018-15518",
      "aliases": [
        "CVE-2018-15518"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/qt/qt5",
              "type": "GIT",
              "events": [
                {
                  "introduced": "afc1ddcee694c24caf97b76cd629e9163a8787ea"
                },
                {
                  "fixed": "1deea3debce6bfd0fd45545b3a8e1de80380a9a5"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:qt:qt:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "5.5.0"
                      },
                      {
                        "fixed": "5.11.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-15518.json"
          }
        },
        {
          "ranges": [
            {
              "repo": "https://github.com/qt/qtbase",
              "type": "GIT",
              "events": [
                {
                  "introduced": "fae33bfbe35f8d082b420ee09662ff60634cb355"
                },
                {
                  "fixed": "08de243eaa007597c2bfbc97d3d14e2f821ac4be"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:qt:qt:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "5.5.0"
                      },
                      {
                        "fixed": "5.11.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-15518.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:40.907282432Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2019/05/msg00014.html",
        "https://lists.debian.org/debian-lts-announce/2020/09/msg00023.html",
        "https://usn.ubuntu.com/4003-1/",
        "https://access.redhat.com/errata/RHSA-2019:2135",
        "https://access.redhat.com/errata/RHSA-2019:3390",
        "https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/",
        "https://lists.debian.org/debian-lts-announce/2019/01/msg00004.html",
        "https://www.debian.org/security/2019/dsa-4374",
        "https://codereview.qt-project.org/#/c/236691/"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
              "cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
            ],
            "vendor_product": "debian:debian_linux",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "8.0"
                  },
                  {
                    "last_affected": "8.0"
                  },
                  {
                    "introduced": "9.0"
                  },
                  {
                    "last_affected": "9.0"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          },
          {
            "cpes": [
              "cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:*"
            ],
            "vendor_product": "opensuse:leap",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "42.3"
                  },
                  {
                    "last_affected": "42.3"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2018-15518",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 435042,
  "published_at": "2018-12-26T21:29:00.823+00:00"
}