Skip to content
Heist/ feed
Back to feed
Medium

GeoServer's GWC Demos Page vulnerable to Stored Cross-Site Scripting (XSS)

Type: advisorySources: OSV

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the GWC Demos Page. Access to the GWC Demos Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-23821
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 15:07 UTC · Revision 1

Source evidence

GeoServer's GWC Demos Page vulnerable to Stored Cross-Site Scripting (XSS)

core-osv · Original source

Published 20 Mar 2024, 18:03 UTC

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the GWC Demos Page. Access to the GWC Demos Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.

osv:CVE-2024-23821
Complete source record
{
  "id": "29e8231bd764dbde2c9b92b2ed7786ce4280049778484595c1e381a8dec72baa",
  "url": "https://osv.dev/vulnerability/CVE-2024-23821",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "GeoServer's GWC Demos Page vulnerable to Stored Cross-Site Scripting (XSS)",
    "summary": "GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the GWC Demos Page. Access to the GWC Demos Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.",
    "evidence": "osv:CVE-2024-23821",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-23821",
      "aliases": [
        "CVE-2024-23821",
        "GHSA-88wc-fcj9-q3r9"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/geoserver/geoserver",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "31f4807730bc3c65ebd6cf2cbda994e178cd3e86"
                },
                {
                  "introduced": "a6665cb505d45b639e62ff178b507914d089a28b"
                },
                {
                  "last_affected": "a6665cb505d45b639e62ff178b507914d089a28b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.23.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:geoserver:geoserver:2.24.0:-:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.24.0-NA"
                      },
                      {
                        "last_affected": "2.24.0-NA"
                      }
                    ],
                    "source": "CPE_STRING"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.24.0-NA",
            "= 2.24.0",
            "2.24.0",
            "2.21-M0",
            "2.11-beta"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-23821.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:51.213816202Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23821.json",
        "https://github.com/geoserver/geoserver/security/advisories/GHSA-88wc-fcj9-q3r9",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-23821",
        "https://github.com/GeoWebCache/geowebcache/issues/1171",
        "https://github.com/GeoWebCache/geowebcache/pull/1173"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23821.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-23821",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 519718,
  "published_at": "2024-03-20T18:03:25.433+00:00"
}