Medium
WordPress Quiz And Survey Master plugin <= 7.3.10 - Cross-Site Scripting (XSS) vulnerability
Type: advisorySources: OSV
Auth. (subscriber+) Cross-Site Scripting (XSS) vulnerability in Quiz And Survey Master plugin <= 7.3.10 on WordPress.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-40698
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 00:42 UTC · Revision 1
Source evidence
WordPress Quiz And Survey Master plugin <= 7.3.10 - Cross-Site Scripting (XSS) vulnerability
core-osv · Original sourcePublished 18 Nov 2022, 21:45 UTC
Auth. (subscriber+) Cross-Site Scripting (XSS) vulnerability in Quiz And Survey Master plugin <= 7.3.10 on WordPress.
osv:CVE-2022-40698
Complete source record
{
"id": "6e325df37c7780e782172803ecfda65c766fd819ffc823367970ffdea3f9b868",
"url": "https://osv.dev/vulnerability/CVE-2022-40698",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Quiz And Survey Master plugin <= 7.3.10 - Cross-Site Scripting (XSS) vulnerability",
"summary": "Auth. (subscriber+) Cross-Site Scripting (XSS) vulnerability in Quiz And Survey Master plugin <= 7.3.10 on WordPress.",
"evidence": "osv:CVE-2022-40698",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-40698",
"aliases": [
"CVE-2022-40698"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/quizandsurveymaster/quiz_master_next",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "ea2a6d5de61225d7016ed3796f0b03c7de320522"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:expresstech:quiz_and_survey_master:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "7.3.11"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"7.3.10",
"7.3.9",
"6.4.2",
"6.4.1",
"6.4",
"6.3.6",
"6.3.5",
"6.3.3",
"6.3.2",
"6.3.1",
"6.2.1",
"6.2.0",
"6.1.2",
"6.1.1",
"6.1.0",
"6.0.4",
"6.0.3",
"6.0.2",
"6.0.1",
"6.0",
"5.3.2",
"5.3.1",
"5.3.0",
"5.2.4",
"5.2.3",
"5.2.2",
"5.2.1",
"5.2.0",
"5.1.7",
"5.1.6",
"5.1.5",
"5.1.4",
"5.1.3",
"5.1.2",
"5.1.1",
"5.1.0",
"5.0.7",
"5.0.6",
"5.0.5",
"5.0.4",
"5.0.3",
"5.0.2",
"5.0.1",
"5.0.0",
"4.7.10",
"4.7.9",
"4.7.8",
"4.7.7",
"4.7.6",
"4.7.5",
"4.7.4",
"4.7.3",
"4.7.2",
"4.7.1",
"4.7.0",
"4.6.7",
"4.6.6",
"4.6.5",
"4.6.4",
"4.6.3",
"4.6.2",
"4.6.1",
"4.6.0",
"4.5.5",
"4.5.4",
"4.5.3",
"4.5.2",
"4.5.1",
"4.5.0",
"4.4.4",
"4.4.3",
"4.4.2",
"4.4.1",
"4.4.0",
"4.3.1",
"4.3.0",
"4.2.4",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"4.1.0",
"4.0.1",
"4.0.0",
"3.9.0",
"3.8.2",
"3.8.1",
"3.7.1",
"3.6.1",
"3.5.2",
"3.5.1",
"3.4.1",
"3.3.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-40698.json"
}
}
],
"modified": "2026-10-28T02:30:48.353067343Z",
"provider": "osv",
"references": [
"https://patchstack.com/database/vulnerability/quiz-master-next/wordpress-quiz-and-survey-master-plugin-7-3-10-cross-site-scripting-xss-vulnerability?_s_id=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/40xxx/CVE-2022-40698.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-40698"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "<= 7.3.10"
},
{
"last_affected": "7.3.10"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/40xxx/CVE-2022-40698.json"
}
},
"related_cves": [
{
"value": "CVE-2022-40698",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 516704,
"published_at": "2022-11-18T21:45:19.326+00:00"
}