Skip to content
Heist/ feed
Back to feed
High

An unrestricted file upload vulnerability in traccar leads to RCE

Type: advisorySources: OSV

Traccar is an open source GPS tracking system. Prior to 5.11, Traccar is affected by an unrestricted file upload vulnerability in File feature allows attackers to execute arbitrary code on the server. This vulnerability is more prevalent because Traccar is recommended to run web servers as root user. It is also more dangerous because it can write or overwrite files in arbitrary locations. Version 5.11 was published to fix this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-50729
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 13:45 UTC · Revision 1

Source evidence

An unrestricted file upload vulnerability in traccar leads to RCE

core-osv · Original source

Published 15 Jan 2024, 15:57 UTC

Traccar is an open source GPS tracking system. Prior to 5.11, Traccar is affected by an unrestricted file upload vulnerability in File feature allows attackers to execute arbitrary code on the server. This vulnerability is more prevalent because Traccar is recommended to run web servers as root user. It is also more dangerous because it can write or overwrite files in arbitrary locations. Version 5.11 was published to fix this vulnerability.

osv:CVE-2023-50729
Complete source record
{
  "id": "48bd85a6011095793c1b18a63a9c9fc54d9484f8e20c015a69bcaf8f78075faf",
  "url": "https://osv.dev/vulnerability/CVE-2023-50729",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "An unrestricted file upload vulnerability in traccar leads to RCE",
    "summary": "Traccar is an open source GPS tracking system. Prior to 5.11, Traccar is affected by an unrestricted file upload vulnerability in File feature allows attackers to execute arbitrary code on the server. This vulnerability is more prevalent because Traccar is recommended to run web servers as root user. It is also more dangerous because it can write or overwrite files in arbitrary locations. Version 5.11 was published to fix this vulnerability.",
    "evidence": "osv:CVE-2023-50729",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2023-50729",
      "aliases": [
        "CVE-2023-50729",
        "GHSA-pqf7-8g85-vx2q"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/traccar/traccar",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "ba1e70e50f6310ec9f331a7e585f004ca4e17298"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.11"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:traccar:traccar:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.11"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v5.10",
            "v5.9",
            "v5.8",
            "v5.7",
            "v5.6",
            "v5.5",
            "v5.4",
            "v5.3",
            "v5.2",
            "v5.1",
            "v5.0",
            "v4.15",
            "v4.14",
            "v4.13",
            "v4.12",
            "v4.11",
            "v4.10",
            "v4.9",
            "v4.8",
            "v4.7",
            "v4.6",
            "v4.5",
            "v4.4",
            "v4.3",
            "v4.2",
            "v4.1",
            "v4.0",
            "v3.17",
            "v3.16",
            "v3.15",
            "v3.14",
            "v3.13",
            "v3.12",
            "v3.11",
            "v3.10",
            "v3.9",
            "v3.8",
            "v3.7",
            "v3.6",
            "v3.5",
            "v3.4",
            "v3.2",
            "v3.1",
            "v3.0",
            "v2.12",
            "v2.11",
            "v2.10",
            "v2.9",
            "v2.8",
            "v2.7",
            "v2.6",
            "v2.5",
            "v2.4",
            "v2.3",
            "v2.2",
            "v2.1",
            "v2.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-50729.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:35.944997324Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50729.json",
        "https://github.com/traccar/traccar/security/advisories/GHSA-pqf7-8g85-vx2q",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-50729"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-434"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50729.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-50729",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 503272,
  "published_at": "2024-01-15T15:57:27.575+00:00"
}