Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2020-15226

In GLPI before version 9.5.2, there is a SQL Injection in the API's search function. Not only is it possible to break the SQL syntax, but it is also possible to utilise a UNION SELECT query to reflect sensitive information such as the current database version, or database user. The most likely scenario for this vulnerability is with someone who has an API account to the system. The issue is patched in version 9.5.2. A proof-of-concept with technical details is available in the linked advisory.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2020-15226
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:52 UTC · Revision 1

Source evidence

CVE-2020-15226

core-osv · Original source

Published 7 Oct 2020, 20:15 UTC

In GLPI before version 9.5.2, there is a SQL Injection in the API's search function. Not only is it possible to break the SQL syntax, but it is also possible to utilise a UNION SELECT query to reflect sensitive information such as the current database version, or database user. The most likely scenario for this vulnerability is with someone who has an API account to the system. The issue is patched in version 9.5.2. A proof-of-concept with technical details is available in the linked advisory.

osv:CVE-2020-15226
Complete source record
{
  "id": "03d7c6d829805e5c12fa7b38bd3a02f4c3bfae7e24d52e46e7623f691627d25d",
  "url": "https://osv.dev/vulnerability/CVE-2020-15226",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2020-15226",
    "summary": "In GLPI before version 9.5.2, there is a SQL Injection in the API's search function. Not only is it possible to break the SQL syntax, but it is also possible to utilise a UNION SELECT query to reflect sensitive information such as the current database version, or database user. The most likely scenario for this vulnerability is with someone who has an API account to the system. The issue is patched in version 9.5.2. A proof-of-concept with technical details is available in the linked advisory.",
    "evidence": "osv:CVE-2020-15226",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2020-15226",
      "aliases": [
        "CVE-2020-15226",
        "GHSA-jwpv-7m4h-5gvc"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/glpi-project/glpi",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "677b4b87af935e23b4aa95c4eff07c1bd87ce8ab"
                },
                {
                  "fixed": "3dc4475c56b241ad659cc5c7cb5fb65727409cf0"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "9.5.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "3dc4475c56b241ad659cc5c7cb5fb65727409cf0"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "9.5.1",
            "9.5.0",
            "9.5.0-rc2",
            "9.5.0-rc1",
            "9.4.1.1",
            "9.4.1",
            "9.4.0",
            "9.4.0-rc2",
            "9.4.0-rc1",
            "9.4.0-beta",
            "9.3-beta",
            "9.1",
            "9.1-RC2",
            "9.1-RC1",
            "0.90",
            "0.90-RC2",
            "0.90-RC1",
            "0.90-beta2",
            "0.90-beta1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15226.json"
          }
        }
      ],
      "modified": "2026-10-20T10:51:53.189173886Z",
      "provider": "osv",
      "references": [
        "https://github.com/glpi-project/glpi/commit/3dc4475c56b241ad659cc5c7cb5fb65727409cf0",
        "https://github.com/glpi-project/glpi/security/advisories/GHSA-jwpv-7m4h-5gvc"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2020-15226",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 383085,
  "published_at": "2020-10-07T20:15:11.99+00:00"
}