High
Post SMTP <= 2.5.7 - Unauthenticated Stored Cross-Site Scripting via Email
Type: advisorySources: OSV
The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 2.5.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-3082
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 13:53 UTC · Revision 1
Source evidence
Post SMTP <= 2.5.7 - Unauthenticated Stored Cross-Site Scripting via Email
core-osv · Original sourcePublished 12 Jul 2023, 04:38 UTC
The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 2.5.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
osv:CVE-2023-3082
Complete source record
{
"id": "8d9fd5970d208e22b5b07655dbc4b99f4c844228c71004db50afa15cc10bea19",
"url": "https://osv.dev/vulnerability/CVE-2023-3082",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Post SMTP <= 2.5.7 - Unauthenticated Stored Cross-Site Scripting via Email",
"summary": "The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 2.5.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"evidence": "osv:CVE-2023-3082",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-3082",
"aliases": [
"CVE-2023-3082"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wpexpertsio/post-smtp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "320e8a9f75a0c3ce374a6e2997f3a77ee548806a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.5.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.5.7",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.5-rc.3",
"2.5-rc.2",
"2.5-rc.1",
"2.5-beta.1",
"2.4.3",
"2.4.2-beta.2",
"2.4.2",
"2.4.1",
"2.4",
"2.4-beta.1",
"2.3.1",
"2.3",
"2.2.1",
"2.2",
"2.2-beta.2",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.4",
"2.1.4-rc.2",
"2.1.4-rc.1",
"2.1.4-beta.1",
"2.1.2",
"2.1.2-rc.2",
"2.1.2-rc.1",
"2.1.2-beta-1",
"2.1.1.1",
"2.1.1",
"2.1",
"2.1-beta.1",
"2.0.27",
"2.0.26",
"2.0.25-beta.1",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"v1.9.8",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v.1.9.2",
"v.1.9.1",
"v.1.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-3082.json"
}
}
],
"modified": "2026-10-28T02:30:50.916973398Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset/2935537/post-smtp",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/6ecd0fa6-4fdb-4780-9560-0bb126800685?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/3xxx/CVE-2023-3082.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-3082"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "2.5.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/3xxx/CVE-2023-3082.json"
}
},
"related_cves": [
{
"value": "CVE-2023-3082",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519532,
"published_at": "2023-07-12T04:38:45.662+00:00"
}