Skip to content
Heist/ feed
Back to feed
High

Slimstat Analytics <= 5.0.9 - Authenticated (Contributor+) Blind SQL Injection via Shortcode

Type: advisorySources: OSV

The Slimstat Analytics plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcode in versions up to, and including, 5.0.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with contributor-level and above permissions to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-4598
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 07:51 UTC · Revision 1

Source evidence

Slimstat Analytics <= 5.0.9 - Authenticated (Contributor+) Blind SQL Injection via Shortcode

core-osv · Original source

Published 20 Oct 2023, 06:35 UTC

The Slimstat Analytics plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcode in versions up to, and including, 5.0.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with contributor-level and above permissions to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

osv:CVE-2023-4598
Complete source record
{
  "id": "18e9eaedd7d3c3365ba98618a0f60f5cd62ff85c139b46c12ac59d3d10f17e10",
  "url": "https://osv.dev/vulnerability/CVE-2023-4598",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Slimstat Analytics <= 5.0.9 - Authenticated (Contributor+) Blind SQL Injection via Shortcode",
    "summary": "The Slimstat Analytics plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcode in versions up to, and including, 5.0.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with contributor-level and above permissions to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.",
    "evidence": "osv:CVE-2023-4598",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2023-4598",
      "aliases": [
        "CVE-2023-4598"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wp-slimstat/wp-slimstat",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1d422261475befae94ca59303c5e0c8414aa1003"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wp-slimstat:slimstat_analytics:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.0.10"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v5.0.9",
            "v5.0.8",
            "v5.0.7",
            "v5.0.6",
            "v5.0.5.1",
            "v5.0.5",
            "v5.0.4",
            "v5.0.3",
            "v5.0.2",
            "v5.0.1",
            "v5.0",
            "v4.9.4",
            "v4.9.3.3",
            "v4.9.3.2",
            "v4.9.3.1",
            "v4.9.3",
            "v4.9.2",
            "4.9.0.1",
            "4.9",
            "4.8.3",
            "4.8.2",
            "4.8.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-4598.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.876865821Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/wp-slimstat/tags/5.0.8/admin/view/wp-slimstat-db.php#L970",
        "https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2959452%40wp-slimstat&new=2959452%40wp-slimstat&sfp_email=&sfph_mail=",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/07c0f5a5-3455-4f06-b481-f4d678309c50?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/4xxx/CVE-2023-4598.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-4598"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-89"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "5.0.9"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/4xxx/CVE-2023-4598.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-4598",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 493550,
  "published_at": "2023-10-20T06:35:06.294+00:00"
}