Skip to content
Heist/ feed
Back to feed
Critical

Dokan < 3.7.6 - Unauthenticated SQLi

Type: advisorySources: OSV

The Dokan WordPress plugin before 3.7.6 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-3915
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 10:21 UTC · Revision 1

Source evidence

Dokan < 3.7.6 - Unauthenticated SQLi

core-osv · Original source

Published 12 Dec 2022, 17:54 UTC

The Dokan WordPress plugin before 3.7.6 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users

osv:CVE-2022-3915
Complete source record
{
  "id": "af3ddb3df9da028d96fe68d20809b005bdfa28cb04718c63a0a0951b31a43891",
  "url": "https://osv.dev/vulnerability/CVE-2022-3915",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Dokan < 3.7.6 - Unauthenticated SQLi",
    "summary": "The Dokan WordPress plugin before 3.7.6 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users",
    "evidence": "osv:CVE-2022-3915",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2022-3915",
      "aliases": [
        "CVE-2022-3915"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/getdokan/dokan",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "dbec0251d8ccd0d4540fcccee0f3df70a6d322e5"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "3.7.6"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v3.7.5",
            "v3.7.4",
            "v3.7.3",
            "v3.7.2",
            "v3.7.1",
            "v3.7.0",
            "v3.6.5",
            "v3.6.4",
            "v3.6.3",
            "v3.6.2",
            "v3.6.1",
            "v3.6.0",
            "v3.5.1",
            "v3.5.0",
            "v3.4.3",
            "v3.4.2",
            "v3.4.1",
            "v3.4.0",
            "v3.3.9",
            "v3.3.8",
            "v3.3.7",
            "v3.3.6",
            "v3.3.5",
            "v3.3.4",
            "v3.3.3",
            "v3.3.2",
            "v3.3.1",
            "v3.3.0",
            "v3.2.15",
            "v3.2.14",
            "v3.2.13",
            "v3.2.12",
            "v3.2.11",
            "v3.2.10",
            "v3.2.9",
            "v3.2.8",
            "v3.2.7",
            "v3.2.6",
            "v3.2.5",
            "v3.2.4",
            "v3.2.3",
            "v3.2.2",
            "v3.2.1",
            "v3.2.0",
            "v3.1.2",
            "v3.1.1",
            "v3.1.0",
            "v3.0.16",
            "v3.0.15",
            "v3.0.14",
            "v2.5.6"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-3915.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.341466480Z",
      "provider": "osv",
      "references": [
        "https://wordpress.org/plugins",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3915.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-3915",
        "https://wpscan.com/vulnerability/fd416d99-1970-418f-81f5-8438490d4479"
      ],
      "provider_metadata": {
        "cna_assigner": "WPScan",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "2.6.8"
                  },
                  {
                    "fixed": "3.7.6"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3915.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-3915",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 518991,
  "published_at": "2022-12-12T17:54:43.952+00:00"
}