Security advisory
An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Roles. Due to the lack of filtering on the role parameter that could be supplied during the registration process, an attacker could supply the role parameter with a WordPress capability (or any custom Ultimate Member role) and effectively be granted those privileges.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-36157
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:15 UTC · Revision 1
Source evidence
An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Roles. Due to the lack of filtering on the role parameter that could be supplied during the registration process, an attacker could supply the role parameter with a WordPress capability (or any custom Ultimate Member role) and effectively be granted those privileges.
osv:CVE-2020-36157
Complete source record
{
"id": "b40cf071c59a9e1974b2293009c0ad55e1503776da1e1650fd4af98e64449f8d",
"url": "https://osv.dev/vulnerability/CVE-2020-36157",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-36157",
"summary": "An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Roles. Due to the lack of filtering on the role parameter that could be supplied during the registration process, an attacker could supply the role parameter with a WordPress capability (or any custom Ultimate Member role) and effectively be granted those privileges.",
"evidence": "osv:CVE-2020-36157",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2020-36157",
"aliases": [
"CVE-2020-36157"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ultimatemember/ultimatemember",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "427bb6da1c2f984b0a0be7013e490496023bdcb6"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:ultimatemember:ultimate_member:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.1.12"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.1.11",
"2.1.10",
"2.1.9",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.5",
"2.1.4",
"2.1.3",
"2.1.3-rc.1",
"2.1.2",
"2.1.2-rc.1",
"2.1.1",
"2.1.0",
"2.1.0-rc.2",
"2.1.0-rc.1",
"2.0.54",
"2.0.53",
"2.0.50",
"2.0.49",
"2.0.48",
"2.0.47",
"2.0.46",
"2.0.45",
"2.0.44",
"2.0.43",
"2.0.41",
"2.0.39",
"2.0.38",
"2.0.37",
"2.0.35",
"2.0.34",
"2.0.24",
"2.0.17",
"2.0.16",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.5",
"2.0.4",
"1.3.88",
"1.3.88.6",
"1.3.88.5",
"1.3.88.4",
"v1.3.88.3",
"v1.3.88.2",
"v1.3.88.1",
"v1.3.84",
"v1.3.83",
"v1.3.82",
"v1.3.81",
"v1.3.79",
"v1.3.78",
"v1.3.76",
"v1.3.75",
"v1.3.74",
"v1.3.73",
"v1.3.72",
"v1.3.71",
"v1.3.69",
"pre-v1.3.69.25",
"pre-v1.3.69.24",
"pre-v1.3.69.23",
"pre-v1.3.69.22",
"pre-v1.3.69.21",
"pre-v1.3.69.20",
"pre-v1.3.69.19",
"pre-v1.3.69.18",
"pre-v1.3.69.17",
"pre-v1.3.69.16",
"v1.3.68",
"v1.3.67",
"v1.3.66",
"v1.3.65",
"v1.3.64",
"v1.3.63",
"v1.3.62",
"v1.3.61",
"v1.3.60",
"1.3.59",
"v1.3.56",
"v1.3.55",
"v1.3.54",
"v1.3.53",
"v1.3.52",
"v1.3.51",
"pre-v1.3.50",
"v1.3.49",
"1.3.48",
"v1.3.47",
"v1.3.45",
"v1.3.44",
"v1.3.43",
"v1.3.42",
"v1.3.41",
"v1.3.40",
"v1.3.39",
"v1.3.38",
"v1.3.37",
"v1.3.36",
"v1.3.35",
"v1.3.32",
"v1.3.30",
"v1.3.29"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-36157.json"
}
}
],
"modified": "2026-10-24T10:31:04.939837783Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins/ultimate-member/#developers",
"https://wpscan.com/vulnerability/33f059c5-58e5-44b9-bb27-793c3cedef3b",
"https://www.wordfence.com/blog/2020/11/critical-privilege-escalation-vulnerabilities-affect-100k-sites-using-ultimate-member-plugin/"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-36157",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 440640,
"published_at": "2021-01-04T18:15:13.777+00:00"
}