Skip to content
Heist/ feed
Back to feed
Medium

AAT allows data exfiltration by other apps installed on the same device

Type: advisorySources: OSV

AAT (Another Activity Tracker) is a GPS-tracking application for tracking sportive activities, with emphasis on cycling. Versions lower than v1.26 of AAT are vulnerable to data exfiltration from malicious apps installed on the same device.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-21615
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 22:09 UTC · Revision 1

Source evidence

AAT allows data exfiltration by other apps installed on the same device

core-osv · Original source

Published 6 Jan 2025, 16:25 UTC

AAT (Another Activity Tracker) is a GPS-tracking application for tracking sportive activities, with emphasis on cycling. Versions lower than v1.26 of AAT are vulnerable to data exfiltration from malicious apps installed on the same device.

osv:CVE-2025-21615
Complete source record
{
  "id": "d530ae3fc0e76c50eb6023e4c54cd5e8c89cea9e80443ca1f75e6e6aae1027c7",
  "url": "https://osv.dev/vulnerability/CVE-2025-21615",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "AAT allows data exfiltration by other apps installed on the same device",
    "summary": "AAT (Another Activity Tracker) is a GPS-tracking application for tracking sportive activities, with emphasis on cycling. Versions lower than v1.26 of AAT are vulnerable to data exfiltration from malicious apps installed on the same device.",
    "evidence": "osv:CVE-2025-21615",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-21615",
      "aliases": [
        "CVE-2025-21615",
        "GHSA-pwpm-x58v-px5c"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/bailuk/aat",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "122fa650877f276e20eb958f77c2d4b06dc27b3b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.26"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.25.2",
            "v1.25.1",
            "v1.25",
            "v1.24.1",
            "v1.24",
            "v1.23",
            "v1.22",
            "v1.21",
            "v1.20",
            "v1.19",
            "v1.18",
            "v1.17",
            "v1.16.1",
            "v1.16",
            "v1.15",
            "v1.14.1",
            "v1.14",
            "v1.13",
            "v1.12-beta",
            "v1.11-beta",
            "v1.10-beta",
            "v1.9-beta",
            "v1.8-beta",
            "v1.7-beta",
            "v1.6-beta",
            "v1.5-beta",
            "v1.4-beta",
            "v1.3.1-beta",
            "v1.3-beta",
            "v1.2-beta",
            "v1.1-beta",
            "v1.0-beta",
            "v0.9-alpha",
            "v0.8-alpha",
            "v0.7-alpha",
            "v0.6-alpha",
            "v0.5-alpha"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-21615.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:23.847203044Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/21xxx/CVE-2025-21615.json",
        "https://github.com/bailuk/AAT/security/advisories/GHSA-pwpm-x58v-px5c",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-21615"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-200"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/21xxx/CVE-2025-21615.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-21615",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490472,
  "published_at": "2025-01-06T16:25:27.758+00:00"
}