ThingsBoard HTTP RPC API resource consumption
A vulnerability has been found in ThingsBoard up to 3.7.0 and classified as problematic. Affected by this vulnerability is an unknown functionality of the component HTTP RPC API. The manipulation leads to resource consumption. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.7.1 is able to address this issue. It is recommended to upgrade the affected component. The vendor was informed on 2024-07-24 about this vulnerability and announced the release of 3.7.1 for the second half of September 2024.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-9358
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 17:32 UTC · Revision 1
Source evidence
ThingsBoard HTTP RPC API resource consumption
core-osv · Original sourcePublished 1 Oct 2024, 01:00 UTC
A vulnerability has been found in ThingsBoard up to 3.7.0 and classified as problematic. Affected by this vulnerability is an unknown functionality of the component HTTP RPC API. The manipulation leads to resource consumption. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.7.1 is able to address this issue. It is recommended to upgrade the affected component. The vendor was informed on 2024-07-24 about this vulnerability and announced the release of 3.7.1 for the second half of September 2024.
osv:CVE-2024-9358
Complete source record
{
"id": "5e2abb6cf93b8e57e80dae136d67b0bd2d383f661fa233a93219b42b16742423",
"url": "https://osv.dev/vulnerability/CVE-2024-9358",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ThingsBoard HTTP RPC API resource consumption",
"summary": "A vulnerability has been found in ThingsBoard up to 3.7.0 and classified as problematic. Affected by this vulnerability is an unknown functionality of the component HTTP RPC API. The manipulation leads to resource consumption. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.7.1 is able to address this issue. It is recommended to upgrade the affected component. The vendor was informed on 2024-07-24 about this vulnerability and announced the release of 3.7.1 for the second half of September 2024.",
"evidence": "osv:CVE-2024-9358",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-9358",
"aliases": [
"CVE-2024-9358"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/thingsboard/thingsboard",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "3528715d2bd5249093ab971bded1fb8b3167210a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:thingsboard:thingsboard:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "3.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.7",
"v2.1",
"v2.0.3",
"v2.0.2",
"v2.0",
"v2.0.1",
"v1.3.1",
"v1.2.1",
"v1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-9358.json"
}
}
],
"modified": "2026-10-28T02:30:30.834546971Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9358.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-9358",
"https://vuldb.com/?id.278887",
"https://vuldb.com/?submit.379486",
"https://vuldb.com/?ctiid.278887",
"https://1drv.ms/v/s!AksJ421iyCG-mytAcEUF6WqOTwj2?e=6WAp5G"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "VulDB",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "3.0"
},
{
"last_affected": "3.0"
},
{
"introduced": "3.1"
},
{
"last_affected": "3.1"
},
{
"introduced": "3.2"
},
{
"last_affected": "3.2"
},
{
"introduced": "3.3"
},
{
"last_affected": "3.3"
},
{
"introduced": "3.4"
},
{
"last_affected": "3.4"
},
{
"introduced": "3.5"
},
{
"last_affected": "3.5"
},
{
"introduced": "3.6"
},
{
"last_affected": "3.6"
},
{
"introduced": "3.7"
},
{
"last_affected": "3.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9358.json"
}
},
"related_cves": [
{
"value": "CVE-2024-9358",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497856,
"published_at": "2024-10-01T01:00:07.228+00:00"
}